2018 Giant Road E Servicing message

ccguy

New Member
I have a 2018 Giant Road E which I've ridden since May, putting 1200 miles on the odometer. Yesterday, when returning from a ride, I noticed a small "wrench" icon on the screen. Today, when I powered up, the icon was gone, but after riding 0.1 miles, the screen blanked out and the message, "Your e-bike needs servicing," briefly appeared. The regular screen then reappeared with the wrench icon again present. No error codes or messages have appeared, and the bike seems to be functioning normally with no mechanical/electronic issues of which I am aware.

Questions:
1) Has anyone else experienced this? If so, did you follow up with a trip to the dealer for servicing?

2) Does anyone know if the servicing message is automatic, generated after a certain time or mileage interval, independent of any "problem" as a reminder to get routine, but perhaps not necessary, maintenance/servicing at the dealer?

Thanks for the feedback.
 

Sedona 10000

New Member
I have one that I bought in April 2018.
Take it in to the dealer- they have a dongle that will identify the code.
My issue happened earlier , May or June, I think. About 400 miles. I now have about 1400 miles on the bike.
I never got a definitive root cause, but they are able to reset it for you.
The dealer should talk to Giant and get the latest service updates.
In my case, I have had the motor, controller, battery, and charger all replaced under warranty.,
The dealer should not charge you for this stuff.
Background-
After doing a lot of research, I felt the best way to get into this ebike thing would be to go with a large manufacturer, with a history like Giant/Yamaha.
I rode the bike at a Giant ride fair and interviewed the local sales rep and asked about what would happen if we had issues, and he gave honest answers.
The process was somewhat arduous due to this being the dealer's first ebike plus the new Road E configuration. Remember, most bike shop guys are good mechanically, but are not system analysts or electrical engineers....
Anyway, the bike is running great, and I am pleased with it, and am quite happy with how my team handled the issue.
Sorry for running on, but I felt I needed to give you the background to help.
Stay in touch !
 

Attachments

RabH

Well-Known Member
I also had the spanner icon appear on my 2018 Road E+1 Pro and I was told the following when I contacted my LBS regarding it "With all E-Bikes there is a service indicator built in which can be reset at the time of the service getting done. It can be reset for 1000 miles or a specific date." My LBS reset it and said it was now set for a period of 2000km, my understanding is it's only a reminder to get your bike serviced so if you can put up with the spanner blotting your screen it shouldn't be anything to worry about!
 

Mtbross

New Member
I have the 2018 Giant Road-E Plus. Have had it a little over a year. Just noticed the little wrench is on the display. My lbs said to run the diagnostics from the Giant RoadControl App, which they said is basically the same test they run at the shop. I did and all is well..no errors or problems. Anyone know how to reset that to make the wrench symbol go away? Would prefer to do it myself as the shop for this bike isn't that close. Thanks.
 

RabH

Well-Known Member
I have the 2018 Giant Road-E Plus. Have had it a little over a year. Just noticed the little wrench is on the display. My lbs said to run the diagnostics from the Giant RoadControl App, which they said is basically the same test they run at the shop. I did and all is well..no errors or problems. Anyone know how to reset that to make the wrench symbol go away? Would prefer to do it myself as the shop for this bike isn't that close. Thanks.
As far as I know only a dealer can reset it but I could be wrong, mine has been on since the start of this month but I'm reluctant to take it to my LBS as I just want to ride it because its just so much fun😁