Battery not charging

#1
I have two Bulls EVO 8's that are a little over a year old. Both batteries went bad and were replaced. When I got the new batteries they charged normally. Over time I have run the batteries down. Mine has two lights left and my wife's bike has three. The chargers show a slow blinking green light, but neither charges after ten hours of charging. Anyone had this problem, or have any ideas as to what to try?
 

AM 4

New Member
#2
I have two Bulls EVO 8's that are a little over a year old. Both batteries went bad and were replaced. When I got the new batteries they charged normally. Over time I have run the batteries down. Mine has two lights left and my wife's bike has three. The chargers show a slow blinking green light, but neither charges after ten hours of charging. Anyone had this problem, or have any ideas as to what to try?
Yes. Happens to me. Try installing the battery on the bike, turning it on then off ,and then plugging the charger into battery whend it's off the bike.
 

AM 4

New Member
#3
Yes. Happens to me. Try installing the battery on the bike, turning it on then off ,and then plugging the charger into battery whend it's off the bike.
The (BMZ) charger will make an audible clicking sound when it turns on. If you do not hear it, it's not actually charging though the light may flash ( at least in my experience with mine).
 

Thomas Jaszewski

Well-Known Member
#4
Firstly those 19 cent gauges are often wrong. Next, it's best to have a multimeter, $10 Amazon, and report actual voltages. It's much easier to help with troubleshooting with more information. You could have a problem charger! Use a multimeter to test that as well.