COBI update bricked my bike :( Haibike Urban Plus Cobi Update Bugs, any fixes?

#1
today while in class the cobi app for my Haibike Urban Plus 2017 model got an update. When i go out to my bike I can't get anything to work and it wants to do an update. Estimated time 4 minutes I wait about 40 then I give up and shut off the phone, reset bluetooth, try again, same thing. I then follow all the suggestions in the application and nothing helps. I bike home at about 9 mph and I get home completely exhausted.

I am so disapointed today with the cobi system. Before it was cool. Now I wan't to bypass it.

Called support. they are open in the USA from 7 am to 12 pm. who closes support at 12 pm?

Tried two different phones, one that had never had the cobi app before, no bueno there either.
Two times the app said the installation was successful but then did the same loop again and didn't work
I couldn't use the power button to turn the bike on and ride with e assist like i normally could. The cobi part was totally dead and wouldn't allow me to power up the bike.
 

Attachments

Last edited:
#2
ok warning: If you have the android app unclick auto update until the next update. Do not allow it to update!
Cobi support is closed on weekends and open very little on the week and I suspect it may be a while for a software resolution to this problem.
I submitted help tickets to Cobi USA and cobi Europe and no help. Who knows how long it will take for a software fix to be pushed out.
 

dblhelix

Active Member
#4
ok warning: If you have the android app unclick auto update until the next update. Do not allow it to update!
Cobi support is closed on weekends and open very little on the week and I suspect it may be a while for a software resolution to this problem.
I submitted help tickets to Cobi USA and cobi Europe and no help. Who knows how long it will take for a software fix to be pushed out.
I am definitely not defending the practice, but noon Eastern time is 6pm in Germany. Back in May, COBI stopped selling products to the US rather abruptly. I believe the only official COBI users in the US are owners of bikes like yours and Bosch bike owners who purchased a COBI unit prior to this action. So the US user base is quite small, and I would assume COBI USA is someone in Germany who infrequently checks the account.

I did a COBI install on a Bosch bike some months ago. I seem to recall that the unit was picky about its internal battery pack charge level. On your images, I see an empty battery symbol. Which battery does this refer to? Try charging up the COBI unit via USB to at least 60%.

I assume there is no alternative controller for the TranzX drive? Have you spoken to your dealer?
 
#5
FYI - Same bike. The version of the Cobi software that is currently installed on my Galaxy Note 8 is 1.11.15
That's what I was updated to. I'm suprised you don't have any issues. It does not work on my LG K20 or MOTO E4. Perhaps it has something to do with the bluetooth chip in both of my phones.

That makes sense on their hotline hours now dblhelix, it didn't make sense to me earlier.
 
#6
Same here...another guy on the google play wrote the same thing. I spoke to Haibike and they said that they can switch it to the Tranzx DP27 that's used on the Winora Radars (european version). I inquired about the price - will report back later.

I can sell you a DP27 compact display and send you the program for the bike to work with it at any time. This can be sold to you directly with a credit card, or thru your local dealer at any time. It’s all pretty easy to do, but it does require the connection to a computer/pc to do the quick programming update.
 
#7
ok warning: If you have the android app unclick auto update until the next update. Do not allow it to update!
Cobi support is closed on weekends and open very little on the week and I suspect it may be a while for a software resolution to this problem.
I submitted help tickets to Cobi USA and cobi Europe and no help. Who knows how long it will take for a software fix to be pushed out.

I just posted an identical issue I had Sunday when it updated automatically. Now the bike is useless since none of the electronics function. I have had responses from Cobi in Germany but they continue to tell me to follow prompts and update....I've done this at least 12-15 times and it stops at 5 min's. I actually let it go for 90 min's till my phone had to be charged.
Frustrating to say the least since i have a bike ride in Vermont in two weeks....I just hope they can revert back to the previous software / firmware update so it would at least funtion.
 
#8
DP27 is $160 shipped from Haibike USA. You will need a mini usb connection to change some settings which can apparently be done from your own computer.
 
#10
What actually is the DP27 and is this a retrofit - I've only had the bike for 4 months.
that is a display that would interface with the Tranzx motor controller and eliminate the COBI system and thus all of our current problems.

Anybody here have older versions of the cobi system or different phones and have no problem?
 

bob armani

Well-Known Member
#13
Half of the problem may be the firmware update to the hub or the software update on the phone. I would try an Iphone if you can, I am assuming there might be significant differences between the two apps
My 2 cents-Sorry to hear about the update failures. I was told the bike can be used without the COBI interface enabled and your smartphone off the carriage holder. Basically riding blind as they paraphrased it. The firmware update completely disabling ALL of the electronics on this bike?!?! That's is crazy and absurd IMO.

Makes me wonder why some of the COBI Haibikes went on sale so quickly at a 50% off retail. One of the dealers gave me a heads up at that time as a buyer beware purchase due to COBI related issues. Seems like the Nyon interface is a better option when using Bosch electronics.
I hope you guys get this issue rectified ASAP! Please keep us all posted on the outcome. Good Luck to all!
 
#14
Half of the problem may be the firmware update to the hub or the software update on the phone. I would try an Iphone if you can, I am assuming there might be significant differences between the two apps
I installed the Cobi on my Android Tablet running Android 7.1 and I was able to "press play" and bring up the speedometer screen. I wasn't able to do that with my phone and I kept getting stuck in a firmware update/recovery loop. I didn't try riding it with my tablet though. I'll try it with my phone again later tonight. I am very confused.
 

bob armani

Well-Known Member
#15
I installed the Cobi on my Android Tablet running Android 7.1 and I was able to "press play" and bring up the speedometer screen. I wasn't able to do that with my phone and I kept getting stuck in a firmware update/recovery loop. I didn't try riding it with my tablet though. I'll try it with my phone again later tonight. I am very confused.
Wow great, at least you have made some progress. I've seen this before where a simple firmware update can crash a system in seconds flat. So much of the unexpected when using smartphones as an interface with E-bikes IMO.
 
#16
Hi,

Fellow Haibike Urban Plus user here. I have an iPhone and I did not experience this problem you are having, bu I just noticed a new update released this afternoon on the Apple Appstore. Have a look on the Play Store to see if they updated Cobi there too. Cheers
 
#17
My 2 cents-Sorry to hear about the update failures. I was told the bike can be used without the COBI interface enabled and your smartphone off the carriage holder. Basically riding blind as they paraphrased it. The firmware update completely disabling ALL of the electronics on this bike?!?! That's is crazy and absurd IMO.

Makes me wonder why some of the COBI Haibikes went on sale so quickly at a 50% off retail. One of the dealers gave me a heads up at that time as a buyer beware purchase due to COBI related issues. Seems like the Nyon interface is a better option when using Bosch electronics.
I hope you guys get this issue rectified ASAP! Please keep us all posted on the outcome. Good Luck to all!
yes if you try and do the update the cobi system basically has no firmware on it if you can't get the update to complete. Otherwise you could use your bike without a smartphone and the cobi interface no problem
 

bob armani

Well-Known Member
#18
yes if you try and do the update the cobi system basically has no firmware on it if you can't get the update to complete. Otherwise you could use your bike without a smartphone and the cobi interface no problem
Thanks for clarifying. I thought perhaps the bike's power source was rendered in-operational due to the faulty firmware update.
 
#19
Well like Raceto100 I didn't have any problem with the latest app/firmware update. It went smoothly. Using an iphone 8.

The only thing I noticed is somehow along the way I lost the power output in watts in the fitness page. I can swear it was working when I got the bike.

Cadence is good, heart rate ok from Apple watch. I did even use the GPS feature a few times but it seems like a few meters imprecise. Even though I love Google maps it kinda sent me on tracks that were not even rideable around my house.

Calories burned after a ride are totally over estimated. An 1/2 hour ride in turbo mode gives me like 700 calories burned. Yesterday even got 1000 calories burned after an easy peasy ride.
 
#20
Well like Raceto100 I didn't have any problem with the latest app/firmware update. It went smoothly. Using an iphone 8.

The only thing I noticed is somehow along the way I lost the power output in watts in the fitness page. I can swear it was working when I got the bike.

Cadence is good, heart rate ok from Apple watch. I did even use the GPS feature a few times but it seems like a few meters imprecise. Even though I love Google maps it kinda sent me on tracks that were not even rideable around my house.

Calories burned after a ride are totally over estimated. An 1/2 hour ride in turbo mode gives me like 700 calories burned. Yesterday even got 1000 calories burned after an easy peasy ride.

Hi,

I just noticed that my power meter stopped working also. Looking at my Strava data the last time I posted power meter data was September 6th. I usually ride with cadence showing so I didn't really notice the missing Power meter until you mentioned it. I'll open a trouble ticket with Cobi to see what they can do.

Cheers