Known Issues & Problems with Magnum Products + Help, Solutions & Fixes

Ann M.

Well-Known Member
No ebike is perfect, this is a thread dedicated to sharing known issues or problems with electric bikes from Magnum as well as any help and solutions you know of. Sometimes that means a DIY fix and other times it can mean a recall, software update or part replacement by a dealer.

Please be respectful and constructive with feedback, this is not a space for hate speech. In many cases, representatives from the company will see feedback and use it to improve their product. In the end, the goal is to enjoy riding and help each other go further and be safer.
 

Maury decoster

New Member
No ebike is perfect, this is a thread dedicated to sharing known issues or problems with electric bikes from Magnum as well as any help and solutions you know of. Sometimes that means a DIY fix and other times it can mean a recall, software update or part replacement by a dealer.

Please be respectful and constructive with feedback, this is not a space for hate speech. In many cases, representatives from the company will see feedback and use it to improve their product. In the end, the goal is to enjoy riding and help each other go further and be safer.
Glad you started this. Love my new bike. Am extolling its virtues to our bike group comprised of older folks. At present Mi where I reside does not have a lot of E-bike owners.
 

Dan Brandon

New Member
Hi, new member here, and just got a new Magnum Peak. I really like it and I've a lot to learn. Found his forum and looking forward to learning and helping.

I am having trouble getting into the set mode on my Magnum Peak. Says to hold down set button for two seconds but nothing happens. Am I doing something wrong? Want to change from kilometers to mph. Appreciate any help.
 

Wayne C

New Member
Hi Dan, also a new member and just stumbled across this site. Hope you were able to resolve your issue by now. If not, take a look at the following site in utube, it should help you out..
Magnum Bikes Das-Kit C7 display settings tutorial
 

Wayne C

New Member
Even though I have watched the above mentioned tutorial, I cannot change the riding mode from power to either normal or eco. It always defaults back to power mode???
 

Gogogordy

Member
Even though I have watched the above mentioned tutorial, I cannot change the riding mode from power to either normal or eco. It always defaults back to power mode???
Have u contacted Magnum in SLC? Cory (technician) specifically.
They were quite helpful to me....
 

Dan Brandon

New Member
I answered this in another category, but unable to find it now. So, just hold down the + and - buttons and you enter a setting mode. There will be 4 zeros. Set the zeros to 8306. It's a passcode for getting in. After that you can set different settings. Look on YouTube and there's a video about how to get in. I think it's under something like How to set up C6 Das Kit. Good luck, hope this helps.
 

Dan Brandon

New Member
Also, you can contact Lindsey at Magnum and she can tell ya about the passcode and how to work things. She was very helpful to me.
 

Wayne C

New Member
Thanks. I contacted Magnum and explained my issue regarding changing the riding mode from power to either normal or eco. Even though I went thru the proper procedure of changing the setting, once done, it would always display "power". I didn't understand that it will always display "power" even though I had correctly changed the setting to either normal or eco.​
 

Dan Brandon

New Member
That's a strange one. Let me check mine and I'll get back. Only thing I've changed is the KPH to MPH. It worked. Try a call to Magnum again. Possible it's a bad display.
 

Dan Brandon

New Member
Wayne, I did check mine and it did as you said. Now wondering how one can change the power setting? Let me know if you find anything else about it. I'll keep looking into it to. May need to call Magnum again.
 

Wayne C

New Member
Blond Angel, yes I can definitely notice the difference between eco and power. Have not tried normal mode yet. Still trying to determine the distance ridden on a full charge.
 
I spoke to the tech guy at Magnum Bikes. Yes, you can change the power modes and the normal display will always say 'Power' but that's normal. Behind the scenes, it will be what you set it to be, be it power, normal or eco.
 

John T

New Member
Hi everyone, I have a magnum Mi5 and have noticed when I wobble the back wheel there is a small amount of movement and you can hear it as well. I took it back to the local shop to get the hub tightened, When I went to pick it up I was told that the hub is tight but the movement is still there? Has anyone else heard of this with their Magnum e-bike or any e-bike?
 

Epic Mike

New Member
Hi everyone, I have a magnum Mi5 and have noticed when I wobble the back wheel there is a small amount of movement and you can hear it as well. I took it back to the local shop to get the hub tightened, When I went to pick it up I was told that the hub is tight but the movement is still there? Has anyone else heard of this with their Magnum e-bike or any e-bike?
That seems odd. Are you located in the United States or Canada?
You can always reach out to magnum directly. In the U.S YOU WOULD NEED to speak to cory. In Canada I would be the one you reach out to.

I would check the rear tire again though as they need to have 40lbs of torque or you need or tighten the spokes
 

John T

New Member
That seems odd. Are you located in the United States or Canada?
You can always reach out to magnum directly. In the U.S YOU WOULD NEED to speak to cory. In Canada I would be the one you reach out to.

I would check the rear tire again though as they need to have 40lbs of torque or you need or tighten the spokes
Cheers, for that.
I'm in New Zealand and we have a distributer hear that I will contact.

UPDATE: my rear wheel was replaced under warranty.
 
Last edited:

Hayley_US

New Member
Hi all, I have a Magnum metro+ that has been constantly breaking rear hub spokes. Im 170 pounds so its not an overweight or loading issue. Has anyone else had issues with rear spokes with this model?
 

Ryno

Member
Hi all, I have a Magnum metro+ that has been constantly breaking rear hub spokes. Im 170 pounds so its not an overweight or loading issue. Has anyone else had issues with rear spokes with this model?
That's a bummer, sorry to hear that. Is it happening on both wheels? What psi are you running? If it is still under warranty I would call Magnum. If not, maybe a lower tire pressure and a better suspension post.