Loss of power

Powysbay

New Member
When out in the wilds of Wales I suddenly lost all power and a fault number came up on the display. Two hours later power was restored. Can anyone advise please?
 

J.R.

Well-Known Member
When out in the wilds of Wales I suddenly lost all power and a fault number came up on the display. Two hours later power was restored. Can anyone advise please?
It's difficult to be sure without knowing the codes. It sounds like a typical overheat shutdown. I've heard Wales has been very hot lately and if you were climbing at speed it may have just overheated. Hope for the best!
 
  • Like
Reactions: JRA

Powysbay

New Member
It's difficult to be sure without knowing the codes. It sounds like a typical overheat shutdown. I've heard Wales has been very hot lately and if you were climbing at speed it may have just overheated. Hope for the best!
It's difficult to be sure without knowing the codes. It sounds like a typical overheat shutdown. I've heard Wales has been very hot lately and if you were climbing at speed it may have just overheated. Hope for the best!
Thanks. It was Friday and it was hot sunshine at the time. We were climbing. I am beginning to wonder if having the battery completely encased is a good thing in these conditions. It was worrying as the nearest road and our car were many miles away over unremitting bog land. Pushing these heavy bikes is no fun through tussock grass. Because of the problem we had to modify the original route. I could really have been serious on shorter days. Can’t remember the code unfortunately. Should have taken a photo of it.
 

Powysbay

New Member
I have now up-dated the firmware so hope that deals with it. I do wonder if Wales is too hot then how the bike copes in really hot places like Utah and California. For me to lose power in the middle of the Elan Valley wild hinterland at my age of 80 is serious.