Need help with the C6 Controller

LewSchiller

Active Member
I need help setting the power levels. I want to try riding in ECO Mode as I'm finding Power Mode to be too aggressive in many situations. When riding as is it seems like all three levels are checked. Power ECO and Normal.
I've downloaded the manual from Magnum's Site but it's not very helpful. The instructions for getting into settings only seem to get me to the trip odometer. Holding SET for 2 seconds does not result in "number 0 flashing at 1hz".
Obviously I'm not doing this properly.
 

LewSchiller

Active Member
Yes - thanks! That confirms my suspicion that it requires entry of password mode to make selections. That's not clear from the manual.
Update: Got in with Password and was able to make the changes I desired.
Thanks to all and Happy Trails!
 

LewSchiller

Active Member
I think I still have a problem - I don't seem to be doing it correctly to save my selections. I set to ECO, hold the set button for a few seconds but then when I leave Setting Mode it reverts to Power Mode. :-(
 

Trail Cruiser

Well-Known Member
I think I still have a problem - I don't seem to be doing it correctly to save my selections. I set to ECO, hold the set button for a few seconds but then when I leave Setting Mode it reverts to Power Mode. :-(
When you are in default screen, the "Power" label pertains to the sliding bar that goes up and down according to the amount of juice you extract from the battery. It has nothing to do with the mode setting that you chose (eco, normal, power).
 

LewSchiller

Active Member
When you are in default screen, the "Power" label pertains to the sliding bar that goes up and down according to the amount of juice you extract from the battery. It has nothing to do with the mode setting that you chose (eco, normal, power).
Ah - so I should still be in ECO mode even though it shows power. Got it.
Feels the same as the "Power" setting though.