New Bike Genesis Battery bad connection

kim

New Member
On the first ride out the bike shut down three times. No lights on and no power.. I found that wiggling the battery made it come back on. It's defiantly a problem with the two pins not making good enough contact. Any suggestions ?
 

kim

New Member
Update.. The Ebay dealer got back to me right away and sent a ph# for tech help but today there was no problem with power.

Update #2.. report the battery must not have been snapped into place the first day... This is a great bike.

Update #3.. there has been no more trouble with this battery connection.. I'm posting again because I don't want anyone to find this in a search and think there is a problem.. These are great bikes.
 
Last edited:

carloabad

New Member
Update.. The Ebay dealer got back to me right away and sent a ph# for tech help but today there was no problem with power.

Update #2.. report the battery must not have been snapped into place the first day... This is a great bike.

Update #3.. there has been no more trouble with this battery connection.. I'm posting again because I don't want anyone to find this in a search and think there is a problem.. These are great bikes.
Has the problem stopped? I have the Genesis as well and the power cuts out on me. I find that I have to push the battery in against the bike for the power to turn back on and it's really annoying. I put in a warranty claim to the company but they have not answered me back. Really annoying and I'm still under warranty.