Range on Display???

kindnblue

New Member
I am not sure if I'm missing something or need to do something different, but my display seems to be working fine except for Range. There is nothing displayed here, well two dashes representing blank numbers.

Is this normal? Bike is a new Stunner.

Thank you.
 

Feliz

Well-Known Member
How far have you gone? It calculates range using your recent mileage. What kind of display is it?
 

kindnblue

New Member
It is the DPC-14 I believe. Have only about 56 miles on the bike so far. I was thinking this was Range on the Battery........
 

Feliz

Well-Known Member
It is range you can ride your bike assuming your riding the same as your last trip. Don't you have a manual? DPC14 is a good display ( if you can see it in the bright sunlight ) and there's manuals for it all over the internet.
 

Feliz

Well-Known Member
I've changed all my DPC14 and 18 displays to the monotone model so I can read them in the bright light but I have poor 80 year old vision.
 

kindnblue

New Member
Yes, I have the manual. And it seems that this should display a km or mileage number. But mine is -- and has been since turning it on the first time. If it needs information about riding styles and battery usage to display a figure, great. If it should be presenting something now, I wanted to know. Thanks for your input Feliz. And yes, I do like being able to see it when riding during the day. Only 51y.o. eyes though! ;)
 

Feliz

Well-Known Member
If it's not displaying anything yet it's probably faulty. Are the trip and odo working. I remember one guy on here was having issues like you are and it turned out it was the magnet on the rear was out of adjustment. Sounds like yours is okay though. Roshan will get another one to you.
 

rich c

Well-Known Member
For reference, Bosch shows a range as soon as you turn on the display and ride a foot.
 

kindnblue

New Member
Yes Trip and Odometer are working, as is everything else. This is the same for Metric and Imperial. Not sure what else to try.
 

kindnblue

New Member
Bumping this up........Still no Range on the Display and after 170 miles, my Battery Percentage icon and info has now decided to disappear intermittently. This happened for the first time today. Have an email out to Rick at Biktrix.....he's been very good about responding.