Shimano Steps problem E20 E10 error

Saklie

New Member
Hi!

I'm having problem with my shimano steps, E6010 controller.

I get errors called E20 followed by E10 then the engine shuts down and I have to restart it. It often happens uphill. Left it in the bike shop but they couldn't find the problem. In the manual it's problem with the electrical connections.

Any one have a clue?
 

Ann M.

Well-Known Member
@Saklie, first which model and year of bike do you have with this controller. We can help you better with this info, please.
 

emco5

Active Member
.. Left it in the bike shop but they couldn't find the problem. In the manual it's problem with the electrical connections....
"020: A communication error between the battery and drive unit."
Did your shop try to diagnose with the eTube software, or just look around and test ride?

On climbs, are you gearing down so the motor can spin easily? If you work it hard at low rpm it might clip to keep the magic smoke from escaping.
 

Saklie

New Member
I'm actually not sure how much they looked in to it. Think that they looked up the cables and stuff like that.

Yes I am. The error doesn't only come uphill. This morning on my way to work (13km) I had to restart 7 times and not a single time when I went back :/
 

emco5

Active Member
That is a bummer. The upside is Trek's good warranty support. Please let know what went wrong.
 

Larry Sloan

New Member
I bot same bike DS+ in March of 2017 in Utah and have same problem. Talked to Trek on phone who told me to take it to LBS for firmware update. Also told me they may charge me for labor as Trek warranty doesnt cover that. Really... i pay $3000 US, the bike doesnt work properly, and the guy has the gall to tell me that!

Anyway, took it to LBS in Calgary who ran the firmware update. No issues for 4 rides then same e020 followed by e012 a few days ago. Reinstalled the battery and good since. Weird. I
Would sure like to get this resolved once and for all.

Can anyone help?
 

Saklie

New Member
Hi all!

I've got my problem solved. Went back to the bike shop and tested with a different battery pack. Tested it a few days and the problem didn't occur. So my problem was a default battery. Got a new one for free :)
 

Larry Sloan

New Member
I have exactly the same behavior. Saklie, can you tell me what you did to solve it?
Just replace the battery? Or more?
Hi Peter

I continue to have E020 followed by E10 errors. LBS talked with Shimano. Shimano says its a connection problem between battery and motor They have asked the LBS to open up motor to check connections.

Ill let you know what i find out.

Larry
 

Saklie

New Member
Hi again guys! Thought I solved this problem but now it's back again. Got the errors six times on my way to work today and had to restart every time. Probably more then just a battery problem. Anyone solved this yet?
 

Peter Meuris

New Member
Yes, the problem for me was solved by replacing the battery. Here is how we found out.
  • Got a testbattery from Shimano
  • Tried commuting with this battery, all was fine
  • Then they replaced the battery for free (still under guarantee)
 

Larry Sloan

New Member
Hi!

I'm having problem with my shimano steps, E6010 controller.

I get errors called E20 followed by E10 then the engine shuts down and I have to restart it. It often happens uphill. Left it in the bike shop but they couldn't find the problem. In the manual it's problem with the electrical connections.

Any one have a clue?
No. Im still struggling to resolve this. Going to try a different battery....not really confident that will solve the problem. LBS took apart motor. No loose connections. I may demand a new bike if this continues. Very frustrating.
 

Saklie

New Member
I'm also starting to think that it doesn't have anything to do with the battery. That's because my problem has starting to show again. To me it sounds like a connection problem.
 

Larry Sloan

New Member
LBS told me that Shimano said they had never seen E020 followed by E010 errors. You and me and others have these problems. I think wr need all to contact Shimano and get them to resolve this???
 
Interesting. As an ebike advocate I like to keep tabs on which brands have good reliability and support. Please do keep this thread updated.

I'm in Calgary as well Larry. Which LBS are you dealing with just out of curiosity?
 

Brant Havro

New Member
I'm also starting to think that it doesn't have anything to do with the battery. That's because my problem has starting to show again. To me it sounds like a connection problem.
Since you have already swapped the battery and it still continues to shut off, it sounds like a connection issue between the battery and motor. This is the Hardness Assy piece in particular or the BM-6010. Contact Shimano for a warranty issue-Aaron if you're based in North America.
 

Dave Rando

New Member
Hi!

I'm having problem with my shimano steps, E6010 controller.

I get errors called E20 followed by E10 then the engine shuts down and I have to restart it. It often happens uphill. Left it in the bike shop but they couldn't find the problem. In the manual it's problem with the electrical connections.

Any one have a clue?