Urban Plus 2 - Cobi Hub will not update and no electronics working.

#1
The blue led (on hub) is flashing constantly and cannot get hub to shut off or respond. Even when battery is disconnected light continues to flash. (will finally stop when battery is discharged!)
Have tried to perform firmware update (at least a dozen times) as prompted but stops at 5 minutes and just keeps spinning stating 5 minutes remaining. (Have tried everything including erasing App and reinstalling, restarting Bluetooth, etc and have contacted Cobi Team and had some communication with them this morning but they said try what I've already done and Hub still will not take update nor Blue LED will not stop flashing. ) I have had bike since May and preparing for a bike tour in Vermont in two weeks...definitely need to have this resolved since currently none of the electronics function including motor, etc.
Cobi released a new software / firmware update recently so not sure if this has anything to do with it.

The hub does respond to ownership, etc but when it prompts to update to required new software this is where it locks up.

thanks