VADO 5.0 Blocks Replacement

Are you still waiting for your VADO 5.0 Blocks Update to Mission Control?

  • Yes

    Votes: 1 100.0%
  • No

    Votes: 0 0.0%
  • Update Completed

    Votes: 0 0.0%

  • Total voters
    1

Ron Friedman

New Member
Hi All, I have a VADO 5.0 (original, delivered late DEC 2017) with the retired Blocks system without Mission Control support. I see the upgrade has been available on other (not 5.0) versions. Has anyone had any luck with having their original VADO TURBO 5.0 updated replacing the NEVER FUNCTIONING BLOCKS to allow Mission Control? Thanks for your reply, and if positive, please advise where this was performed. Thanks.
 
Ron, the Specialized dealer in my area promised replacing BLOKS with the Mission Control compatible TCD-W soon. I will report when it has been done.
 
Bad news also for you @Ron Friedman.
My Vado 5.0 was diagnosed by the Specialized dealer in Warsaw. They "could not" replace the BLOKS display with the new TCD-W because "the TCD could only be used with the 25 km/h version of the Vado not with the 45 km/h one". In my opinion it is a pure lie and the guys were just incapable to replace the display. They, however, "found and fixed software bugs", that is, installed software updates for the BLOKS.

My Vado works fine now, I can only not use the benefits that TCD displays give such as Mission Control app capabilities.

Ah, that were "Specialized" who told him so. I wonder.
 

PaD

Well-Known Member
Bad news also for you @Ron Friedman.
My Vado 5.0 was diagnosed by the Specialized dealer in Warsaw. They "could not" replace the BLOKS display with the new TCD-W because "the TCD could only be used with the 25 km/h version of the Vado not with the 45 km/h one". In my opinion it is a pure lie and the guys were just incapable to replace the display. They, however, "found and fixed software bugs", that is, installed software updates for the BLOKS.

My Vado works fine now, I can only not use the benefits that TCD displays give such as Mission Control app capabilities.

Ah, that were "Specialized" who told him so. I wonder.
Ok, I’m guessing here.
Is your 5.0 the model with the rigid fork? If so then your motor is probably the 1.2S ( or Brose TF)
Could the motor version ( and its software) be the limiting factor?
 
Last edited: