Recent content by Jwcarmo

  1. J

    How to tell if I’ve fried my controller.

    OK, I've put a multimeter on the four throttle wires coming out of the controller: Red, Yellow, Green and Blue. When I read volts between the red and blue its 4.5V, between yellow and blue it's 40V. I can't seem to find any wires that connect to "ground", not even the blue wire. Not getting any...
  2. J

    How to tell if I’ve fried my controller.

    Good on you HarryS. Let me try those tips and I'll report back. it seems I may have burnt out an in-line fuse of some sort and I cut that out and installed a new on-line fuse. So I'm ready to try the throttle again. Thanks for the support.
  3. J

    How to tell if I’ve fried my controller.

    Hello All, I’ve been riding the ProdecoTech Phantom X2 for seven years. It has a 36V system with a 500W hub motor. Now that ProdecoTech is hard to contact (what’s going on with them?), I need some advise. How can I tell if I’ve fried my controller? I‘m having a throttle issue (power button...
  4. J

    Hello All I have a throttle wiring issue

    Well thanks for responding to my message, Buzzard. I’m going with adding new connectors and wiring it as I’ve seen on the web. The colors don’t match entirely, but I will give it a go. Thanks for checking.
  5. J

    Need Help with Throttle Wiring

    Hello, Jwcarmo here who has been riding a ProdecoTech Phantom X2 since 2012 and loving it. However, The thumb throttle recently broke (actually the On/Off switch fell apart) and I ordered a 36V replacement on the interweb. Now that I’m ready to replace it, I found out the original uses just four...
  6. J

    Hello All I have a throttle wiring issue

    Hello, Jwcarmo here who has been riding a ProdecoTech Phantom X2 since 2012 and loving it. However, The thumb throttle recently broke (actually the On/Off switch fell apart) and I ordered a replacement on the interweb. Now that I’m ready to replace it, I found out the original uses just four...