6 months, mixed feelings about my ST1

Machiel

New Member
Hi, my name is Machiel and I am from The Netherlands. I bought my ST1 for commuting. It is 43 km one way, which is doable with not too much headwind. I really like the looks of the bike and its superior handling. But there are a few issues, unfortunately.

First, the chain drops off regularly on bumpy roads. Quite annoying. Second, the speed indicator makes some strange discrete jumps at certain speeds. Not a big issue, but still...

The third problem occured already after one month: the button for unlocking the battery kind of exploded. The spring inside got kind of launched through my garage.

My dealer ordered a new one (after further messing up the locking mechanism), but it has been five months now! I have called them several times, but they blame Stromer for not sending it.

And my fourth problem occured today. At 13% capacity, I lost power completely. After recharging, I noticed that for many km, the battery indicator remained at 100%. Even after 43 km, the level remained unrealistically high (over 50%). So, I concluded that the indicator is broken or got wrongly calibrated all of a sudden.

I wonder, has anyone had this last issue too? What could be causing this?
 

fxr3

Active Member
Hi, my name is Machiel and I am from The Netherlands. I bought my ST1 for commuting. It is 43 km one way, which is doable with not too much headwind. I really like the looks of the bike and its superior handling. But there are a few issues, unfortunately.

First, the chain drops off regularly on bumpy roads. Quite annoying. Second, the speed indicator makes some strange discrete jumps at certain speeds. Not a big issue, but still...

The third problem occured already after one month: the button for unlocking the battery kind of exploded. The spring inside got kind of launched through my garage.

My dealer ordered a new one (after further messing up the locking mechanism), but it has been five months now! I have called them several times, but they blame Stromer for not sending it.

And my fourth problem occured today. At 13% capacity, I lost power completely. After recharging, I noticed that for many km, the battery indicator remained at 100%. Even after 43 km, the level remained unrealistically high (over 50%). So, I concluded that the indicator is broken or got wrongly calibrated all of a sudden.

I wonder, has anyone had this last issue too? What could be causing this?
 

fxr3

Active Member
Those problems are not exactly minor... Especially the 5 months waiting on part.
Call Stromer direct on part problem- anyone who manufacters such an awesome product is not the one responsible for the part not showing up. My Stromer experience has been better- just bought an st2 after 18 months of bullet proof service from my st1.
 

JoePah

Well-Known Member
Machiel, the Stromer state of charge indication is not very reliable esp When the battery is near the low voltage cutoff. You can try to get warranty repai but they will tell you it is normal

And you'll find that the battery degrades after the first year by about 20%. If you want to keep the bike buy a larger second battery.

Maybe the Stromer $7000 eBike is more reliable. Lol
 

fxr3

Active Member
My battery has not degraded by 20% in a year and a half. It's been charge prolly 200 times. My st1 charge indicator has always seemed accurate.
And, my st2 is proving to be as awesome as st1. Call stromer direct on all these issues- dealer is not taking care of business.
 

Machiel

New Member
Thank you all. Calling Stromer directly is a good idea, I guess. And a nice opportunity to practice my German. There is no agent in my country, so I will have to call their HQ in Switzerland.

I forgot to mention another piece that broke down. The spring of the little bell broke as well.
 

Berlin

New Member
Thank you all. Calling Stromer directly is a good idea, I guess. And a nice opportunity to practice my German. There is no agent in my country, so I will have to call their HQ in Switzerland.

I forgot to mention another piece that broke down. The spring of the little bell broke as well.
Dear Machiel,
Are your problems already solved?
If the answer is a yes, are you pleased with your ST 1
Who about the battery problem?
And how many km can you travel with 1 charge ( a speed limit approx. 35-37km/ hour)
Thx
 

MLB

Well-Known Member
Chain falling off isn't normal, and should just be an adjustment. Mine's never fallen off.
Most charging weirdness seems to involve on bike charging port. (me too)
Take battery out and charge see if back to normal.
 

Brambor

Well-Known Member
I think the chain is just an adjustment issue but the battery door locking mechanism is problematic. I literally received a new Stromer and could not open the door or remove the key and the solution was to send me a replacement Stromer. Fast forward 1 year and this morning my key got stuck again and could not be turned or removed. After some fiddling and thanks to the fact that the battery door was OPEN I was able to turn the key and remove it but I am worried that it will happen again under less fortunate circumstances like being unable to open the door to remove the battery and having the key stuck in forever mode.
 

Machiel

New Member
Dear Machiel,
Are your problems already solved?
If the answer is a yes, are you pleased with your ST 1
Who about the battery problem?
And how many km can you travel with 1 charge ( a speed limit approx. 35-37km/ hour)
Thx
My bike is at the dealer now. I will pick it up after my holidays, so I can't tell you yet if everything is solved. But I certainly hope so! My range is usually around 45 to 50 km. But they say it gets less in time.
 

JoePah

Well-Known Member
Machiel, my Stromer Elite starts acting erratically around 15%. The SOC indication jumps around then the battery just shuts off. Best way is to just plan on your battery only being available 100 to 15%.

A range of 50 km in PAS PWR mode is pretty good with the smaller battery. Hope it holds up for you!
 

Machiel

New Member
Machiel, my Stromer Elite starts acting erratically around 15%. The SOC indication jumps around then the battery just shuts off. Best way is to just plan on your battery only being available 100 to 15%.

A range of 50 km in PAS PWR mode is pretty good with the smaller battery. Hope it holds up for you!

I forgot to mention I had the large battery.

The dealer has replaced the chain and the rear sprocket, if that is the correct term. This should solve the problem with the chain falling of. I have my doubts, because it also happened when chain and sprocket were almost new. But we will see.

The door locking mechanism and the display have also been replaced.
 

Berlin

New Member
Do you have an elite or a platinum crank set, I mean a single or a three -course crank set.
I thought this sometimes caused problems with the elite. Perhaps install a chain guide, and/or increase the chain tension (less slack chain).
Good to hear, display and battery lock replaced. Yes, the lock is really a troublemaker. (I mostly charge 'on the to bike')