7 Problems in 14 Days Ownership: 2021 Trek Domane HP Electrical Bike You Should Avoid At All Cost

Dallant

Well-Known Member
Region
USA
Thank you for the light info. I have a Allant+8S and the lights have never blinked from day one. I am away for the summer and will return home in 2 weeks. My LBS is very good and they will fix my lights. The kicker is that you say only the back light flashes. My buddy up here has the same bike and both the front and the back flash. He has never had his software updated since August 2020.
I’m going to ask for my light to be fixed and that I be given the ability to turn them off. When I bought the bike I asked about the ability to turn them off and he said something to the effect that Trek would not allow that. I thought about cutting the wires if not given the ability to turn them off and no see your post with a solution. I’ll update this reply after I visit my LBS in 2 weeks.
It certainly worked for me to have the light on/off option enabled on my Allant+7, however, my lights do not flash nor was that option available.
 

Hefeman

New Member
Region
USA
Bought a Domane +HP at the beginning of June. 644 miles. Zero problems. If my spokes kept breaking on a new bike, I'd want a new rim. Maybe there's a crack somewhere undermining integrity. That specific issue seems unrelated to whether a bike has a motor or not.
 

ubt

New Member
Region
USA
I have about 500 miles on my HP+. I did have a motor drop-out issue when I took delivery (every now and then I'd hit a bump and the Kiox would turn off), which the shop was easily able to fix by adjusting the battery position. The dealer showed me the service bulletin from Trek for that specific issue. No other issues other than the usual derailleur tuning and tweaking the fit to dial things in.

It probably helped that the dealer's HP+ demo bike is also the manager's personal bike.
 

drodg

Active Member
Btw I have a rattle noise I think up front somewhere on my Domane HP. At times I think it could be the front wheel or the disc brake and then other times I think it sounds like it could be the motor. This is on sharper bumps or rougher roads. I have just under 1400 on mine. Love it. Any ideas?
 

pmags

New Member
Region
USA
Check the nut on the valve stems or even secure the stem with some tape. I've had that be the cause of many mystery rattles.
Thanks for suggesting this. I too had a mysterious front end rattle I couldn't locate -- turned out it was a loose valve stem nut just as you suggested!