Bafang KD58C display locked - any solution?

swechsler

New Member
Region
USA
I have a Macwheel Macmission 100 entry level 36V ebike; bought from Woot last year. It came with a Bafang Key-Disp KD58C display. The display doesn't allow any entry into setup, such as to reset the trip odometer. According to the manual, to get into setup, hold the Up and Down buttons for 2 seconds, but this does not work. I've tried every combination of buttons to no avail.

I purchased a replacement KD58C display off of Aliexpress (Macwheel doesn't support their customers at all); this one did allow me to get into setup, but displayed a communications error whenever I tried to use the bike. Since my original display still worked fine when reconnected, I assumed it was a defective display (when received it was not packaged as if it was a new item) and Aliexpress gave me my money back once I showed them a picture of the display with the error message showing.

Before I go any further, I'm wondering if there is a known way that the bike manufacturer has locked the display, and if there is a way out of it (there is no mention in the bike's manual of resetting the trip odometer, nor of getting into setup). If not, should I try again with a display from a different seller on Aliexpress (that seems to be the only marketplace where this display is available)? Or are there other displays that are compatible?

Thanks.