Bafang M600

Stu

New Member
I have a relatively new ebike, 300mi since Christmas, This M6oo motor seems to have 2 problems. The first seems ot be getting better, it use to cut out randomly after it warmed up. It would just stop for a second and then kick back in after a couple of revolutions. The PAS would just stop, but the throttle worked fine. Anyone have a clue. I am thinking the torque sensor.
The next problem is more of a bother. It is just very load when the running. LIke maybe it needs grease. I build a couple of other ebikes with Bafangs, The 500W and another with a 750 W motor. They made a bit of sound but not like the M600. I am really disappointed in the bike. Its a FLX trail and there have been a bunch of problems with it. If any one knows how to make it quieter I'll try it.
 

byunbee

Well-Known Member
The only option I know for the M600 noise is the peek nylon gear that’s supposed to reduce the noise by roughly half. It’s $100 from Luna Cycles.

 

TomD

Well-Known Member
Yeah, get the quiet gear, it will be a life altering experience (greasing the metal gears won't really help with the noise, it's just a loud motor with the metal reduction gear). Sorry to hear you are having problems with your motor. My Ultra will intermittently cut out over bumps. I think it is either the shift sensor or brake sensors getting triggered, but sounds like your problem is more sustained and related to the motor warming up? What did FLX say, assuming you can get a hold of them? I have not heard good things about FLX support lately. Good luck!
 

Stu

New Member
Their customer service does suck The bike does ride well when it works right. The new motor does not seem to cut out but it is still noisy I might just live with until the warranty expires. My 2other bafangs 750 and 500 work well and quiet. Thanks