Bafang spared me a walk home!

BafangFan

New Member
I installed a Bafang BBS-02 750w motor in my Norco Storm 9.1 earlier this week and have been riding it to work ever since. It's been great for my 7-10 mile (one way) hilly Seattle commute. Each day I've been attempting different routes with progressively steeper hills. Today was a big test - riding up Fremont Avenue. It's about a 260 feet climb in just under a mile.

I had my bike serviced earlier in the day to fix a poorly adjusted derailer. The mechanic lifted the bike with a Park Tool mechanical lift. I'm not sure if it had anything to do with the problem I later encountered.

For the first time all week, my left crank started coming loose on my way home, on the sections that were uphill so I was pedaling faster. The first two times I was able to tighten the bolt that held the crank on before the crank fell off. (Good idea to carry all the tools you used to install the Bafang for a week or two in case anything comes loose.)

The third time the crank started to come loose, I was at the bottom of Fremont Ave. At first I tried to make it up the hill with throttle only, but my 16.5ah battery has the 29E cells, and I think I experienced voltage sag as the bike was studdering (in first gear). Pedaling in first gear with assist at level 7 got me halfway up the hill, at which point the crank and pedal fell off. The threads in the bottom bracket were a little buggered, so I didn't want to force the bolt back in. I was also halfway to home, and stuck on a hill. Would have been a sucky walk.

Thankfully I'm relieved the Bafang was torquey enough to get me up the rest of the hill without pedaling, and there was still plenty of battery left after my 20 mile round-trip commute, as I didn't see any bars missing from my battery indicator.

TL/DR: Crank fell off. Couldn't pedal. Bafang strong enough and em3ev.com's battery big enough to get me the rest of the way home on throttle only.
 

BafangFan

New Member
The bike runs on 29" tires, and the front chain-ring is the default Bafang 46 tooth (right?). The back looks like a 34 tooth. I was doing about 17-19 mph in first gear on the flats at full throttle. Now that I write it out it sounds like pretty tall gearing.
 

Kado!

New Member
I had the problem you described, and just recently fixed (not solved) it. Check if your motor nuts have worked loose, allowing the motor to pivot down, even slightly. If so, read on. If not, good luck!

My story. Scott Sportster hybrid bike, aluminum frame, converted March 2015. A few months ago, the left crank worked loose and fell off just like you describe, going uphill. The bottom bracket nut for the motor also worked loose, causing the motor to swing down from the frame. I cranked down the nut on the motor and tightened the crank bolt, and had to do it again a few weeks later. Added Loctite to both.

2-300 miles later, was getting a weird rhythmic click while pedaling, same point at every stroke. Checked the motor mount, it was pivoting, maybe 1/16 of an inch. Pulled the crank and then the bottom bracket nuts and then the locking bracket. Turns out the splines from the locking bracket had dug into the aluminum bottom bracket, letting it pivot as described. Most importantly, the BBS02 crank axle element was wobbling in the bottom bracket. My take is that the crank wobble caused the locking bracket pivot and eventually resulted in the crank working itself loose.

My fix was to put a sleeve between the crank axle and the bottom bracket to eliminate the wobble. Used a cut up pop can. Also pivoted the motor down slightly so the locking bracket could have a fresh bite, and added cable ties to hold the motor up to the frame. It has been working okay, but the motor still pivots slightly, which I'll fix when I need to.

I love my conversion and the BBS02 is a champ. For me, these little issues add to the charm. Just needs a little care. Good luck!
 

BafangFan

New Member
Thanks for the reply, Kado. That will be something for me to watch out for. Sometimes I think I feel phantom wobbling in the left pedal, but the crank is on tight, so I chalk it up to paranoia.

I also did the cut-up pop can to use as shims where the crank connects to the bottom bracket, but will see if the bottom bracket axle needs shims down the road. If it lasts two years and then fails, it may be a good excuse to get the new Bafang 1000w motor.

I used a torque wrench and red loctite on the crank this time around, and was really surprised how much effort to it took to get to around 27 foot pounds.
 

Eivind Rinde

New Member
I have also lost the crank M8 nuts, on left side. Is this a standard DIN934 nut or is it another standard? Where can I get it ?