Battery indicator lights

dmahalek

New Member
After a full charge, or after a partial discharge, the bottom indicator led on the battery does not light up. After my 13 mile ride today, the display indicator shows three bars remaining, the photo shows the indicator lights on the battery. Any ideas why the bottom indicator LED is not working? Tech-support at RAD told me that this was normal and nothing to be concerned about.
IMG_5018.JPG
 

mrgold35

Well-Known Member
I have 3 Radrover batteries and all LEDs on light up when fully charged. I usually use the power display on the LCD screen most of the time for an estimate of my battery charge level.
 

hfk2

New Member
My Radrover battery always shows three green and one red light. The three largest lights are always green the bottom small red one is red. Doesn't change from full charge to discharge. Rad bikes said use the controller it is more accurate. It's just kinda of a pain because I always store the battery indoors so never quite sure how much juice is left.
 

Lost

Active Member
The best is a volt gauge. Solder to a power plug and get the real story. (Link Removed - No Longer Exists)
 

Doug Devine

New Member
I checked with a multi meter and at full charge I had 54.3 v.
I always get 54.6V on a full charge. I think you should too. 54.6 makes sense since it's 13*4.2. 13 is the number of cells in series in the pack and 4.2 is the voltage each cell gets charged to.

Regarding the LED indicator light, I have a cordless drill battery with 3 indicator lights to show voltage status but one of the lights failed. It turned out the LED connection was faulty. I had to re-solder it. I kept wondering why it wouldn't fully charge. It was so aggravating. But it was fully charging the whole time...it just couldn't tell me correctly.