battery problem?

Mickey

New Member
Help! I realize that there's this thread
https://electricbikereview.com/forums/threads/help-troubleshoot-assist-just-stops.5121/
but I would apppreciate your advice.

In the middle of a ride, the controller turned blank and there was no power. The battery light showed that there was a charge and in fact the battery was fully charged the evening before.

I now can't get the controller to turn on and I can't get any electric power. Luis called and said the battery can overheat, but in my opinion that shouldn't be the case 5 miles into a ride on flat paths.

Even if I can fix it, how can I (or anyone) go out for a long ride in the middle of nowhere and have the electric system break again? I should add that this is my third eBike, so I'm not a complete novice.

If anyone has solutions please let me know. I think the design and concept behind the CrossCurrent is excellent and the price is a bargain. Thanks.
 
Last edited:

Marc V

Member
Wow, sorry to hear and I will keep an eye on this thread as I currently own a Juiced Bike, hope you get it worked out!

I currently own a Juiced ODK U500 V3 (2nd eBike) and have worked with Juiced Support on a few support cases and they have been very helpful (even Tora himself responded to one of my support cases).

I couldn't tell by your post if you already have a current support case with Juiced Bikes? If not, I recommend getting one ASAP so you can nip this in the bud. UPDATE: I see you said Luis called you, which I assume you are talking about Luis from Juiced. Either way I hope it all gets sorted out!

Good luck!

Take care, ride safe!
Marc V
 
Last edited:

Dunbar

Well-Known Member
If the display goes blank while you're riding in my experience it's one of two things 1) the battery is bad or 2) the battery is losing its connection. If the battery has been working fine up until now than it's probably not bad . If you have a local dealer maybe they can give you another battery to test out.
 

Tora Harris

Well-Known Member
Our understanding is your bike has sustained some significant damage to the cables during shipping. This could cause a malfunction of the bike. Please get in touch with tech support and we can better assist you to get your bike working as it should. support@juicedbikes.com / Technical Support: 1-888-303-8889 (Extension #2)
 

Mickey

New Member
Thanks. I've been in touch with tech tech support, which has been helpful.
Dunbar was right on target: apparently the battery dislodged from fitting well, and the connection was off.

All is fixed, at least for now. Thanks.
 
Last edited:

Dunbar

Well-Known Member
You might still need to do try the velcro fix if you lose power sporadically (over bumps etc.) while the display stays on. I was one of the beta testers of the 17.4Ah battery and the first one they sent me would cut out over bumps but the display stayed on.