BBS02 Makes clicky/knocking noise under load

Swing Ninja

New Member
So my bafang BBS02 makes clicky/knocking noise under load with or without the motor on. Please see the video below. It only happens when it's ramping up. But after at a certain speed (around 8mph+), the clicking is gone. What I've tried so far:

  1. Throttling while parked, with no load. Everything is fine, no clicky/knocking noise.
  2. Pedaling with hand while parked (no load). Also fine.
  3. Make sure the chain lined up. The chain never came off.
  4. No wear and tear on sprocket and chainring.
So I think it's something to do with bottom bracket. Any advice before I start dissasembling or is there anything else I should look at? Is it really the bottom bracket? This is my second e-bike I built (with same motor and battery if that matters). Thanks.

ebike video link
 

rich c

Well-Known Member
There's no true bottom bracket left with a BBS02 is there? Knocking noise can come from loose cranks, loose pedals, and even a loose saddle since your butt is rocking back and forth while pedaling.
 

Swing Ninja

New Member
It's the part that goes into the bottom bracket area. Kinda like what's shown in this video. I've opened up the motor before, but just to put some moly grease.
 

Swing Ninja

New Member
Thanks for the link. That helps a lot in investigation. I kinda suspected there's some sort of internal gear change mechanism, because it sounds like my 90's car automatic transmission switching gears. It only happens when I ramp up/throttling up the motor.