Belt replacement?

Ken S

Active Member
Has anyone seen instructions for splitting the frame when replacing the belt on a Charger3?

Can't find anything anywhere on this.

On an initial look it appears that the frame split is accomplished via the two large black ( 2 on each side) Torx screws normally used to loosen the wheel when adjusting the belt tension. I assume if these are removed or loosened (further than adjusting) the frame can be split to slide the belt in.

Comments appreciated.
 

JVBulman

Well-Known Member
Region
USA
You've got the idea - remove those two black T40 bolts that hold the sliding driveside drop-out in place. After that it's just a matter of force.

One tip is be careful not to pinch the belt while installing it - I recommend the plastic handle of a small screwdrive or something similar to keep the two split parts of the frame far enough apart to move the belt past easily.

Good luck.
 

Ken S

Active Member
You've got the idea - remove those two black T40 bolts that hold the sliding driveside drop-out in place. After that it's just a matter of force.

One tip is be careful not to pinch the belt while installing it - I recommend the plastic handle of a small screwdrive or something similar to keep the two split parts of the frame far enough apart to move the belt past easily.

Good luck.
Thanks
Got it done couple hours ago, no surprises. Was hoping not to run into some SNAFU which does happen working on bikes, but it all went well and I'm back on the road again.
If I hadn't messed up and used a petroleum based silicone spray on the belt I likely would have got another 10K+ out of the original belt, but 17,000 kms is not too shabby. Live and learn.

Cheers
 

JVBulman

Well-Known Member
Region
USA
Glad it went off without a hitch. Curious - what did the silicone spray do to the old belt?
 

Ken S

Active Member
Glad it went off without a hitch. Curious - what did the silicone spray do to the old belt?
It caused the teeth to be stripped from the belt.

I've used CRC brand a couple of times over the last year with no issue. I picked up some WD40 brand "multi surface" the other day, used it last Saturday, 20 hours later on a test ride before my planner trip the teeth started to strip away.
The wd brand states petroleum distillates the CRC does not state this.
 

Kiwibru

New Member
Wow, scary bad. Guess it's best to not use any type of lube or solvent other than water for a cleaning.