Bosch Performance CX not powering up correctly

IdeFix

New Member
Hi everyone,

I have been looking around the forum but not able to find someone with the exact same issue as I have.
But please let me know if I have overlooked a similar thread.

I got a Mondraker Panzer-R with a Bosch Performance CX system using a Purion display.
In the middle of my ride the bike shut off, while I still had 2 bars left on my battery indicator.
After riding home I removed the battery and charged it. Once it was full I put it back on to the bike.

The display powers on, however, the battery indicator is still at 2 bars while the indicator on the battery itself shows a full charge (5 bars?).
I notice that the speed value/digits are not showing
the Purion display will allow me to cycle the speeds (+/-) but the system shuts off after a few seconds

The bike is clean and well maintained, there are no obvious faults or breakage to cables etc.
What worries me is that the display does not register correct battery level and that it powers itself off after just a few seconds. The main indicator as I see is that the speed digits are "missing".

I also tried replacing the batteries in the Purion, but this had no effect (also verified healthy batteries with a multimeter)

I tried disconnecting all cables to the motor, they are all clean, nothing sticks out as an issue. Only power, display and speed sensor are connected.
I have never modifed or done any alterations to Bosch system.
The main battery itself is secure, and not lose, and remember the issue is also present in the work-stand.

Anyone got any ideas what to try next?
thank you in advance

EDIT: I checked the speed sensor with my multimeter and I see that the numbers are jumping around. Does anyone know how the system would react if there is no speed sensor attached?
 
Last edited: