Cell overload error and engine not really assisting and phone app....

Yayabike

Member
Region
Europe
I m still happy with my orbea but i have issues with the X35 system.

- First i got an error message (633 , cell overload) so i contacted orbea and followed the procedure to try to fix the issue (bring bat to 0% and do a few things). It failed, orbea nicely took back the bike and it seems that they just changed the firmware. I hope it won' t happen again. This cell-overload problem seems to be really commons since i read another post about it.

- Second the algorithm to assist is really buggy, on a 7% slope, with my scott city bike i run around 12-14km/h (i m 50+ and recovering from surgery + covid + confinement + ...) but with the Orbea i m at 16 ? with less efforrt.
With my friend basic decathlon bike I m over 20 it s a much heavier bike that sell around 1200 euros with also a 250w engine. It also seems to me that it is assisting much less than 6 monthes ago. It is very werid, may be i m pushing to hard and using a lower gear would mean less pressure more turn and may be more assistance or the other way around.
It is very very weird, a champion like Froome deliver 400 watts while climbing Alpes d huez at 25-30, so 250 + me should really allow me to reach 25 on any slope lesser than 8%.

- Third i cannot find a way to unlock the speed toward 30-35. This possibility should be enabled, it is our responsability. When i go down hill i m above 60 and my friend (bolder, heavier) it over 70. When it is flat i can be over 40 and when i was 20-25 i was much faster. The 25 rule is just stupid, the US norms are much sounder.
Please le me know is the 99euro device actually work ....It is very expensive but 5-10 extra km/h would made me much safer for a very simple reason on mo road the traffic average speed is below 40, so a bike at 30-35 does not make car diver mad and irritated, but a bike at 20 does.

- Fourth what application should I use ? I m using the Mahle application but its odometer get reset all the time and it also forget my bike. On top when i hit the start button it does not starts since it wants a GPS signal. The GPS signal is purely optionnal, the speed can be read from the sensor so why does it behave that way ? Also when i stop i have more clicking to do to " save" the activity. It should save is and tag it with the date. So the activity should start immediatly while still looking for a gps signal and use it once it get it. First i had a better app which was showing the power output of the engine which was nice but it has been replaced by this Mahle app which is even worst, the new Mahle app does not display the engine power.

Last i may end up buying a 1000 euros chinese speed bike with 500 watts and 40 km/h max speed....