Charger Not Charging

Adam319

New Member
So I just got my bike put together. Magic pie with a sunthing 15ah 48v battery. It took the first charge ok and now I believe the charger isn't working anymore. I have contacted sunthing for help and am awaiting a response. The charger puts out 0VDC when just plugged into the wall. I seem to remember a fan on there the first time I plugged it in. Now the fan doesn't even turn on....just a green light on the left and red light on the right of the charger all the time regardless of battery plugged into it or not. Does anyone else have one of these batteries? Any ideas to keep me going?
It was fun to build this bike....I actually want to sell it and build another for the hey of it.
 

George S.

Well-Known Member
The charger should be at 57v or so. Probably dead. See what they say. I have a Sun Thing charger, been doing the job for a year. I assume they will replace it. If it's an Ebay deal you can always post bad feedback. With long shipping times the window to post feedback can run out. Good luck. If you are forced to buy a charger, a 48v Lifepo4 is not the same as a standard LiOn charger. It is slightly higher voltage. EM3ev sells them, sometimes labeled as A123 chargers.
 

Adam319

New Member
Thanks George. Sun Thing contacted me back and is going to send me a new charger. Hopefully it doesn't take 3 months to get here like the battery.
 

Adam319

New Member
Does anyone know the internal fuse amperage. It is popped and I was going to pick one up on way home tonite but forgot to look before I left this am.
 

Adam319

New Member
Yeah. I know. Su thing came with decent reviews. He said he will send me a new charger. Asked to help on shipping, but didn't say how much?? I am worried this may end up a bms issue and by that point I am out of options for eBay. Should i open a dispute on it?
 

George S.

Well-Known Member
Double check the connector. A lot are just bad. I cut mine off and put an XT60 on it. Then replace the fuse. If it blows and you are sure the connector is OK, file a dispute.
 

JoePah

Well-Known Member
The fan on my "high Power" charger quit after 4 years and would not charge. Took it apart and found it to be a typical Desktop CPU fan. $4 and I had to slightly modify the mounting holes.. It's worth fixing if you do not have to send them the old one back.

For a new charger you should either get a new one, or they should send you the fan.. plug and play.
 

Adam319

New Member
Wow. So I finally got the package from sun thing and he sent me a Bms. What in the heck? I emailed him and he said he sent the wrong part. He then in turn replied back that I need to replace the BMS. I just emailed him back to remind him of our emails earlier and that the charger puts out 0VDC. What a nightmare
 

Adam319

New Member
Thought I would give a update. Got a working charger from sun-thing finally today. I am not going to fault somebody for being half way across the world with slow shipping. It happens and you need to be prepared for it. But, sun-thing is a person of their word and I appreciate it. So now...my ass is on the road!!!