Charging issue.

Douglas Ruby

Well-Known Member
I posted an email to Marco Sondregger, Product Manager of the Specialized Turbo development in Switzerland. I referred him to this thread. Hope that helps.

Doug
 

John Dombrowski

Active Member
Here's is what I heard from the Specialized Rep:

Regarding the issues you’re having:
1. We have an updated component for the lights that addresses the charging issue.
2. There is a firmware update the fixes the battery percentage. This is the result of a slight difference in tolerances between what the battery and charger interpret as a full charge.
3. The odometer reset issue is the result of an occasional hiccup in how the system saves the ride data when the bike is turned off. The firmware update that fixes the battery State of Charge improves this but unfortunately it still happens occasionally. The team is actively working on getting that where it needs to be.
So, we can get two of these taken care of and let you know when the last one is resolved. I understand how the Odometer reset is annoying- I have the same battery on my Turbo that I ride daily so I can empathize with you- but know that it is a minor bug that we’re taking care of. Because I’m running that same battery I am also test new FW versions before we share them with retailers.
 

John Dombrowski

Active Member
The new batches of Turbo S's are due to be shipped this month so I am waiting on getting my new, 3rd, Turbo S. Hopefully I will get one that works this time or I think I will call it quits on the S and might have to lean towards a Stromer.
 

Richard Spensley

New Member
Hi John, were you having this issue with the new 2016 charger (the smaller, black charger that has now replaced the travel charger), or was it with the large, finned unit?
 

John Dombrowski

Active Member
Hi John, were you having this issue with the new 2016 charger (the smaller, black charger that has now replaced the travel charger), or was it with the large, finned unit?
There are 3 chargers right now. The big finned unit that comes with the base Turbo, the new smaller unit that comes with the S model, and an even smaller travel charger. I have all 3 and all 3 do the same thing.
 

jwb

Member
My brand new base Turbo purchased August 2016 does the same thing: charges to 98%, then fault light on the charger comes on. Never gets to 100%. I have the more compact rectangular charger, not the finned one.
 

John Dombrowski

Active Member
My brand new base Turbo purchased August 2016 does the same thing: charges to 98%, then fault light on the charger comes on. Never gets to 100%. I have the more compact rectangular charger, not the finned one.
That's the problem. That's the one that came with my Turbo S and I had them order the big finned one like the one that came with my wife's base Turbo. Problem solved. Still doesnt hit 100% every charge but at least it shuts off now when it's done and the lights on the bike go off like they are supposed to. Their support is terrible. I have emailed them a dozen times and never hear back from them. I give up. Next bike with be a Stromer for sure.