Cube Agree Hybrid C:62 Race Disc E-Bike 2019

mattgod69

New Member
Region
United Kingdom
I have the above ebike which overall i am very happy with. Today the seat clamp broke (my torque wrench was set to 5.5Nm..... i am wondering if anyone else had experienced this and if a standard clamp would fit (the frame is carbon). Also, i am getting squeaking from i think the seat or seat post (which is why i was checking the tightness of the clamp). Has anyone any thoughts or tips on how to solve the issue. Many thanks in anticipation. Matt
 

skritikos

Member
Region
Europe
City
Athens, Greece
Can you please share photos of the seatpost clamp before and after? If the frame is carbon, is the seatpost carbon too?
Which torque wrench you use?
 

mattgod69

New Member
Region
United Kingdom
Hi.... yes i think the seat post is carbon. please see attached pics of the seat, borrowed clamp off and old bike (which seems fine) and the old broken clamp. My torque wrench is a Pro Bike Tool 1/4 Inch Drive Set.
 

Attachments

  • Bike Seatpost and Clamp 1.jpg
    Bike Seatpost and Clamp 1.jpg
    185.6 KB · Views: 38
  • Bike Seatpost and Clamp 2.jpg
    Bike Seatpost and Clamp 2.jpg
    230 KB · Views: 47
  • Bike Seatpost and Clamp 3.jpg
    Bike Seatpost and Clamp 3.jpg
    164.6 KB · Views: 38
  • Bike Seatpost and Clamp 4.jpg
    Bike Seatpost and Clamp 4.jpg
    312.3 KB · Views: 42
  • Bike Seatpost and Clamp 5.jpg
    Bike Seatpost and Clamp 5.jpg
    114.5 KB · Views: 36
  • Bike Seatpost and Clamp 6.jpg
    Bike Seatpost and Clamp 6.jpg
    113.1 KB · Views: 34
  • Bike Seatpost and Clamp 7.jpg
    Bike Seatpost and Clamp 7.jpg
    149.5 KB · Views: 36
  • Bike Seatpost and Clamp 8.jpg
    Bike Seatpost and Clamp 8.jpg
    129.6 KB · Views: 32
  • Bike Seatpost and Clamp 9.jpg
    Bike Seatpost and Clamp 9.jpg
    139.2 KB · Views: 32

skritikos

Member
Region
Europe
City
Athens, Greece
Open a support case with Cube or through your local dealer! With the broken bolt it seems like overtorque has been applied but still...
About the temp clamp, be sure that the height of the clamp part is equal to the original one. If not you are risking the integrity of the carbon fiber tube.

I think Cube will easily sort this out for you though!
 

mattgod69

New Member
Region
United Kingdom
Hi, thanks for the reply and advice. I am careful not to overtighten (it says up to 6Nm), but i think that to try and get to the bottom of the creaking and squeaking i have undone many times in the past few weeks.... the temp clamp fits really well and is almost if not the same depth as the original.... tightened to 2Nm. I'm not totally convinced there was not a problem with the other clamp. There is no creaking and squeaking now... i am wondering if the clamp ahs been weakened a bit which was why it failed..... i have contacted Cube, they have not responded yet.
 

skritikos

Member
Region
Europe
City
Athens, Greece
One of the reasons I hate all this full integration trend! Proprietary parts and complexity for things we could do easier with classic clamps, stems, handlebars, etc
I can see some benefits for some very aero designed bikes but not for a normal road bike. Lets see what Cube will say!

Have you had any kind of carbon assembly paste on the seatpost and seat tube? Or just plain grease? Or nothing at all?