DIY fixing a FlyKly wheel that stopped working


New Member
Hi all. I am starting this as a new thread to make it easier to find. Previous discussion happened in this thread (with Iaroslav Timofeev), and I suspect this other thread (with LdnJon and Maurizio) is also related.

If your wheel has suddenly stopped working but still turns the lights on / connects to the app via Bluetooth, it could be the same issue. Iaroslav came up with a possible cause: one or more of small box-shaped magnets (really small: about 1mm x 1mm x 5mm) being displaced, perhaps by a harder bump while cycling. He added an image to this post where you can see three of them attached to the metallic axle. He said that putting the magnets back in place made the wheel start working again.

I attempted to fix my wheel in the same way about a month ago, but at the time I had misunderstood what he was referring to, and thought the displaced pieces were these larger ones held in place by a spring -- see images below:

IMG_20170129_205831.jpg IMG_20170129_210123.jpg

Most likely that piece came out of place while disassembling the wheel. So naturally, having not found the actual magnet and put it back in place, the wheel still didn't work after that.

Today I took the wheel apart again and found the actual magnet that was out of place (I didn't realize it was going to be so small). I'll make a follow-up post in this thread with more details and images.


New Member
Ok so here are some notes and images that hopefully may help others facing the same problem.

First of all: there's an official video by FlyFly showing how to take the sprocket out, which is enough to expose the part of the wheel we're interested in looking at. It's hosted at vimeo: FlyKly How To: Change the Sprocket.

Second: here's what the displaced magnet looks like (there was only one in my case):
Coupled with Iaroslav's photo from the other thread, there should be no issues finding the magnets if that's the problem with your wheel as wheel.

Third: putting the magnet back in place is a little tricky. There's a tiny hole for it to fit next to the others in the sprocket. It fits there quite easily, but in my case there wasn't a tight fit, so the magnet didn't hold in place; the other ones seemed to be quite solidly held in place. You can see how it can easily be tilted out of the correct position by just applying slight pressure on one of the ends:
IMG_20170228_182529.jpg IMG_20170228_182519.jpg
This did not happen with the magnets that weren't displaced -- pressing on them didn't budge them one bit. So I decided to glue the magnet in place, to avoid having it come loose again. However, I'm not recommending that -- if you want to do the same, do it at your own risk.

One note about positioning: the magnets seem to be magnetized transversally -- i.e. rather than the top and bottom of the piece corresponding to the poles, actually one of the long sides is the north pole, and the opposite side is the south. So to figure out the correct orientation, you have to hold it and bring it close to the existing magnets. They are alternated: one magnet's north pole faces out, the one next to it has the north pole facing in, and so on. So you'll want to place the magnet in the orientation such that the two adjacent magnets repel it -- meaning that the pole it has pointing in is the same one the adjacent magnets have pointing out.

So that's about it -- Now that the glue is dried, I'm going to reassemble the wheel. I'll report later if the wheel starts operating correctly after this.


New Member
My wheel shows fully charged with the charger plugged in. Unplugged it shows no charge, gives a little kick when I pedal then switches off. Magnets are all in place. Batteries are 4.1v each, so the fully charged report with the charger connected is genuine. Can't get my head around why it's showing zero charge in run mode?


New Member
Hi Kris. Unfortunately, I am starting to think these wheels are simply failing in different ways. Iaroslav hasn't posted yet to confirm whether his wheel has started working, but in my case after disassembling and reassembling the wheel several times (see photos below), I still can't get it to turn on. The light turns on, I can connect to the app, the battery shows 100% charge and the pedal sensor reports the correct speed... everything seems to be ok but the motor just doesn't activate. I ran out of options, and will attempt contacting Zehus once more to see if it pays off to send the wheel to them for repair, paying for all costs. I'm not holding my breath :(

Do let us know if you manage any progress with your wheel. Good luck...


  • IMG_20170322_222016.jpg
    1 MB · Views: 2,077
  • IMG_20170322_222410.jpg
    914.5 KB · Views: 1,919
  • IMG_20170322_222558.jpg
    1.3 MB · Views: 2,210
  • IMG_20170322_222439.jpg
    1.2 MB · Views: 1,946
  • IMG_20170322_222423.jpg
    1.3 MB · Views: 2,005
  • exploded-1730px.png
    742.3 KB · Views: 2,046


New Member
Zehus reckon they are opening an office here in Sydney Australia next month so I might get a fix then. Seems my issue might be down to an internal comms problem. Will report back if I get any progress.

Yee Wei Wen

New Member
There is a small piece of carbon contact (i think) broken off. I scrapped away the silicon filling, see the photo, this is the weak point.


  • IMG_9187.JPG
    876 KB · Views: 815

Yee Wei Wen

New Member
The dislodged carbon contacts are suppose to brush along the inner ring of this gear.


  • IMG_9189.JPG
    745.2 KB · Views: 812


New Member
I appreciate this posting with the photos and all. I have a flykly smart wheel with about 1300 km logged that has stopped working too. Just like the above posts, the battery is full, the blue lights come on, but the motor never initiates. I do not get a speed reading when the wheel is turning on my bike stand. The regenerative braking does not initiate either. I'm guessing it's a problem with those poorly placed magnets referenced in above posts. I have not tried to open it yet as I'm waiting to get the proper tools (hex/ torque style screwdriver, etc.). The only thing I have really done different is that I ride with my daughter on a seat in the front of my bike. So the "rider" weight has technically crossed over 200 lbs. Not sure why that would matter, but after about 5 years it's the only thing that has changed. Although historically there have been plenty of soft resets (wheel returns to 60% assist factory setting) with this wheel when I go over big bumps and wheel gets knocked around a bit.