EBike sensor battery low warning on M20 Gain

Mike Cannona

New Member
I have a 2021 M20 Gain connected to the ebike page on a Garmin 830. At least once a ride sometimes more my Garmin shows a message at the bottom of the page “Ebike sensor battery low. “ Today it even said dangerously low. I can’t see anywhere that a speed sensor, if that’s what it’s referring to, can be accessed on this bike. The bikes battery is always adequate when this warning appears. Anybody know if it’s something with the Garmin or the Gain?
 

Yayabike

Member
Region
Europe
What level does hte The bike indicator display (Iwoc or frame button) i never remember but white means over 75? and green is 50+, fast flashing red is below 10%.
What level do you read on the Mahle application ?

I never tried to pair my garmin, i don' t think that ebikes are well supported.
 

Mike Cannona

New Member
My bike battery ranges from >30% to >75% per Iwoc when it has appeared on the Garmin, no reason to prompt the indication I am getting. The pairing of the Gain with the Garmin was flawless. Iwoc and Garmin agree on battery level. Probably a dozen rides since I got it. Just this weird notification on the Garmin. I was on a 34 mile ride Tuesday, 4k ft. climbing in the middle of nowhere with 30% bike battery and I got another notification which this time read "Ebike sensor battery critical." Crap, I thought I'd be done for but nothing actually happened. Guess the Garmin thinks there is a separate speed sensor, not knowing the Gain's sensor in the chain stay is wired right into the bike's battery. I'll just ignore it in the future. I know some bikes use a 2032 battery in their sensor.
 

Yayabike

Member
Region
Europe
weird.

I have a Garmin edge 520, i think i saw an ebike menu but i never tried to pair my Orbea vibe with it. May be i will try.