eflow e3Nitro 2013 not charging

Decomsoft

New Member
I recently got this electric bike boxed and brand new. Tried to charge the battery, but the charger LED would just turn green immediately. When I installed the battery on the bike, and when I power the bike ON, the LCD would just show an empty battery icon with one bar blinking. What could be the issue? A dead battery?
 

Evgeny Begin

New Member
There may be two reasons: a faulty battery or a faulty charger.
You can try to find a similar charger with the same charge voltage and with the same connector, and try to charge the battery.
But you need to make sure that the contacts on the connector are connected in the same way, B+ and B- correspond on both connectors.
If the battery starts to charge with other charger, the problem is with the charger. If not, then the problem is in the battery.
 

Decomsoft

New Member
Thanks Evgeny, I have three similar bikes and all behaving the same even when I interchange the charges/or the batteries. Confusing, could be that all the three batteries or chargers are dead? Maybe? All the three were boxed, but the shipment took more than three months to arrive to me, possibly the batteries got flat and dead? If I measure the voltage I am getting less that a volt, is there a way to recover the cells or if they are dead they are dead 😥
 

Evgeny Begin

New Member
By the way, perhaps the charger needs to be turned on differently: first insert the connector into the battery, and then plug the charger into a power outlet. Try this way. I think it will help