Error 21

ispeak3

New Member
Hey,

So for the past month or so my CCS has randomly stopped assisting me with power, and occasionally it will end up giving me an "error 21" on the screen. When I don't get the error, the display stays on and functions as normal (speedometer works, changing PAS level, etc...) It seems to happen at random, but always after a period of not pedaling (either from a stop or after coasting). I've contacted support and they've asked me to check on multiple things. First cleaning the sensor area, checking all of the connections and putting a strap around the battery. None of those have helped.

They said to send in the rear wheel for inspection, so I'll do that when things calm down.

I'm mostly posting this here to see if anyone else has experienced this and if there are any other tips. I'd love to fix/figure out the problem myself without much down time because this bike is my main mode of transportation. I'm curious whether it really is the motor or sensor.

Here is a video I got of it:
 

CityExplorer

Active Member
when the throttle is not working, as in the video, the PAS is also not working? How do you fix it? Just turn it on/off from the Controller? On/off from the battery? Or either? Always starts working again after 1 power cycle, or sometimes multiple are needed?
 

ispeak3

New Member
when the throttle is not working, as in the video, the PAS is also not working? How do you fix it? Just turn it on/off from the Controller? On/off from the battery? Or either? Always starts working again after 1 power cycle, or sometimes multiple are needed?
Right the PAS is not working either. Sometimes turning it off/on once works, but usually it takes multiple attempts. That day I got the video, was the worst because I about 3/4s the way to work and no matter how many times I turned it off/on, it wouldn't work again. So once I got to work I locked it as usual and checked it an hour or two later and it was working again.

Did Juiced happen to tell you what Error 21 actually meant?
From their website: https://support.juicedbikes.com/hc/...at-does-the-ERROR-XYZ-mean-on-the-LCD-display
It says it's a "sensor speed fault" and that's what Juiced seemed to think it was from the beginning. Although, for whatever reason they now think it's a motor issue. Maybe it's because of the sound from the video... I don't know.