Error code 30

beegee226

New Member
Region
USA
I was out riding my x3 pro today and the motor just stopped with Error Code 30, communication failure. I disconnected and reconnected all of the cables from the display, all the way down to the motor. I even opened up the compartment with the controller and checked that connection. Nothing fixed the issue. I ended up pedaling my bike back home for 10 miles. I've only had the bike for a month. I emailed support and messaged Wallke on FB but I'm not getting any response. @Max Black can you help me out with this?
 

Attachments

  • 20210215_140711.jpg
    20210215_140711.jpg
    110.3 KB · Views: 18
  • 20210215_150032.jpg
    20210215_150032.jpg
    182 KB · Views: 16
  • 20210215_145858.jpg
    20210215_145858.jpg
    228.9 KB · Views: 20
  • 20210215_145906.jpg
    20210215_145906.jpg
    213.9 KB · Views: 20
  • 20210215_150016.jpg
    20210215_150016.jpg
    136.1 KB · Views: 16

Taylor57

Well-Known Member
I was out riding my x3 pro today and the motor just stopped with Error Code 30, communication failure. I disconnected and reconnected all of the cables from the display, all the way down to the motor. I even opened up the compartment with the controller and checked that connection. Nothing fixed the issue. I ended up pedaling my bike back home for 10 miles. I've only had the bike for a month. I emailed support and messaged Wallke on FB but I'm not getting any response. @Max Black can you help me out with this?
Try this number. This guy posted in the Wallke forum earlier and offered his number.

You can msg me here or call me @ 862-266-2923

Xplore Wallke

 

ryukenden73

Active Member
code 30 is loss of communcation between lcd and controller.


if you are still getting the problem, definitely need to contact wallke support: sales@wallkeebike.com
 
Last edited:

beegee226

New Member
Region
USA
I sent Wallkee a video of my disconnecting and reconnecting all of the connections showing nothing fixing the problem. They ended up shipping me out a new controller and pedal sensor. It's supposed to be here on Wednesday. My bike has been shut down for 1 week, can't wait to get it going again.
 

tomjasz

Well-Known Member
Error 30 can also be a harness failure. We see overtightened
zip ties that have cut into the very small AWG wires in the harness. While not a DIY bike, I'd still be looking very hard at the wiring. And consider using your multimeter to test for wire continuity.
 

Max Black

Active Member
If you see all of the assist lights flashing on the display, and the bike shuts down or displays ERROR 30, there may be a communication problem between the controller and display.

How To Troubleshoot Wallke Electric Bike Error code 30 Problems?​

1. Unplug the sensor connector and restart the display. Is the error code 30 still there?
2. Replug the sensor connector, Unplug the throttle connector and restart the display. Is the error code 30 still there?
3.Replug the throttle connector, Unplug the headlight connector and restart the display. Is the error code 30 still there?
4.Replug the headlight connector, Unplug both the brake level connectors and restart the display. Is the error code 30 still there?
5.Please check if the connector wires are damaged?

Note: Please Check all the connections and make sure they are connected properly. This is almost always the result of a poor connection. If the issue persist, please check for any twists or bends in the wiring harness.
If it still shows error 30, please contact Wallke Ebike team.
 

beegee226

New Member
Region
USA
If you see all of the assist lights flashing on the display, and the bike shuts down or displays ERROR 30, there may be a communication problem between the controller and display.

How To Troubleshoot Wallke Electric Bike Error code 30 Problems?​

1. Unplug the sensor connector and restart the display. Is the error code 30 still there?
2. Replug the sensor connector, Unplug the throttle connector and restart the display. Is the error code 30 still there?
3.Replug the throttle connector, Unplug the headlight connector and restart the display. Is the error code 30 still there?
4.Replug the headlight connector, Unplug both the brake level connectors and restart the display. Is the error code 30 still there?
5.Please check if the connector wires are damaged?

Note: Please Check all the connections and make sure they are connected properly. This is almost always the result of a poor connection. If the issue persist, please check for any twists or bends in the wiring harness.
If it still shows error 30, please contact Wallke Ebike team.
I did all of that and still got error code 30 after each one. I think it's either the display, the motor, or the connection to the motor.
 

beegee226

New Member
Region
USA
I got a new controller and display from Wallke yesterday and swapped them out . Still no luck, I'm still getting error code 30. So far, I have changed out 2 controllers, the wiring harness, the pedal sensor, and the display and remote. Still waiting on the next steps from Wallke. My bike has been down for 2 weeks now.
 

ryukenden73

Active Member
I got a new controller and display from Wallke yesterday and swapped them out . Still no luck, I'm still getting error code 30. So far, I have changed out 2 controllers, the wiring harness, the pedal sensor, and the display and remote. Still waiting on the next steps from Wallke. My bike has been down for 2 weeks now.
It could be the motor itself.
 

ryukenden73

Active Member
🤣 Well given that he tells us he's replaced all devices and wiring harness and still has an issue... what would you guess?
I'm thinking he's overlooking something simple. I lean towards a bad wiring harness

"So far, I have changed out 2 controllers, the wiring harness, the pedal sensor, and the display and remote"

Might be the actual motor.. :(