Error code 30

PedalUma

Well-Known Member
Region
USA
Jim, a mellow fellow, only rode his bike a couple of times. He is pissed. The customer support is almost non-existent. And they charged him $89 for the $16 PAS sensor. He feels like junking the bike. He ordered the PAS sensor in October and it just arrived and did not to the trick. CODE 30!
If anyone is wondering where your bikes and parts are, there are 26 huge container ships at anchor of the Port of LA. Normally there might be one waiting to unload. https://www.marketplace.org/2021/03/08/dozens-container-ships-waiting-unloaded-port-los-angeles/
 

tomjasz

Well-Known Member
"So far, I have changed out 2 controllers, the wiring harness, the pedal sensor, and the display and remote"

Might be the actual motor.. :(
I'm not intending to be an asshat....
This is why I kit rather than buying an OEM complete eBike. All my rides are built with easily accessed repair parts. These budget builder direct bikes are either a win-win, or a support nightmare. I wish buyers understood their choice make them the ebikes support.
 

beegee226

New Member
Region
USA
Jim, a mellow fellow, only rode his bike a couple of times. He is pissed. The customer support is almost non-existent. And they charged him $89 for the $16 PAS sensor. He feels like junking the bike. He ordered the PAS sensor in October and it just arrived and did not to the trick. CODE 30!
If anyone is wondering where your bikes and parts are, there are 26 huge container ships at anchor of the Port of LA. Normally there might be one waiting to unload. https://www.marketplace.org/2021/03/08/dozens-container-ships-waiting-unloaded-port-los-angeles/
Surprisingly the parts made it here fairly quickly from China considering. I've had 3 shipments that all went out on a Thursday and were here by Monday or Tuesday. I do live in Socal, so that speeds it up. Just wish one of those shipments solved my problem.
 

beegee226

New Member
Region
USA
Finally got Wallke to send me a new motor. It arrived as a bare rim with the motor. I had to move the brake rotor, rim liner, tube and tire over to the new rim and install. All is good now. Hopefully this motor doesn't burn out any time soon!
 

ryukenden73

Active Member
Finally got Wallke to send me a new motor. It arrived as a bare rim with the motor. I had to move the brake rotor, rim liner, tube and tire over to the new rim and install. All is good now. Hopefully this motor doesn't burn out any time soon!
as sherlock holmes said ... "When you have eliminated the impossible, whatever remains, however improbable, must be the truth."
 

WayneCAlderman

New Member
Region
USA
I've gone through 2 new controllers with no luck.
we all going thru the same problems I'm getting the error code 30 too and just changed out the display and the controller cable that was fried still no luck I guess buying chinese bikes are not good at all EaHora AM100
 

WayneCAlderman

New Member
Region
USA
I was out riding my x3 pro today and the motor just stopped with Error Code 30, communication failure. I disconnected and reconnected all of the cables from the display, all the way down to the motor. I even opened up the compartment with the controller and checked that connection. Nothing fixed the issue. I ended up pedaling my bike back home for 10 miles. I've only had the bike for a month. I emailed support and messaged Wallke on FB but I'm not getting any response. @Max Black can you help me out with this?
this showing you need the usb cable and download the drivers to the motor
 

tomjasz

Well-Known Member
this showing you need the usb cable and download the drivers to the motor
Isn’t the EaHora AM100 a hub drive? I’m maybe mistaken but I’m pretty confident they don’t have much in common with the mid drive you referenced. In the BBSxx series error 39 can also be a bum controller. But have more difficulty trouble shooting and just sloppy electronics QC.
L
 

WayneCAlderman

New Member
Region
USA
yeah these bikes are impossible to troubleshoot online not even many of the professionals know how to fix them, it did say the Error code 30 could be many different things
 

tomjasz

Well-Known Member
these bikes are impossible to troubleshoot online
I'll try to remember that during my daily support calls. 🤪

More often than not, user error is often an issue. If I had a dollar for every, "my wiring is fine" response I could buy that 15-year-old single malt I'm missing.

Support is the single biggest problem with these direct-to-consumer eBike sellers.

Another dollar for every, "I don't have a multimeter" response would get me a 750ml Johnny Walker Blue.

Believe me, I know how frustrating this can be. I'm firmly in the have a backup controller, ready group. As well as a speed sensor and a cheap display to troubleshoot issues. When we buy those bikes we're expected to be our own repair support.
 

WayneCAlderman

New Member
Region
USA
I'll try to remember that during my daily support calls. 🤪

More often than not, user error is often an issue. If I had a dollar for every, "my wiring is fine" response I could buy that 15-year-old single malt I'm missing.

Support is the single biggest problem with these direct-to-consumer eBike sellers.

Another dollar for every, "I don't have a multimeter" response would get me a 750ml Johnny Walker Blue.

Believe me, I know how frustrating this can be. I'm firmly in the have a backup controller, ready group. As well as a speed sensor and a cheap display to troubleshoot issues. When we buy those bikes we're expected to be our own repair support.
exactly, well this is why EaHora wanted me to get a multimeter and check to see if the display was putting out power or not or even the controller, which for my bike they had to send me a new display and the control box cable I put them both on and still getting this error, just hope I'm not like this other guy said he changed just about everything on his bike and still no luck. waiting for my mom to get home so I can get the order number for my bike which is on her amazon page, it sucks now since amazon changed the way people login to others accounts firefox it resets all the time and google is the only way to get in, a few on here said with the usb cable that would be for the mid drive motors and they saying mine has a hub motor so maybe the new drivers won't work so I'm stuck there. I seen the download drivers but thats for a total different bike.