[EXPIRES June 10th] WALLKE eBike $150 Coupon Code

JDsplice

New Member
Region
USA
WALLKE eBike $150 Coupon code WALLKECHAD01. Add to cart, fill out delivery page, and then add coupon code at payment page.

2021 X3 Pro in stock on sale for $1,849.89 w/code. Free shipping, no tax.
Typically ships UPS from California, US about 10 days or less arrival.
 
Last edited:

johnwebike

Member
Region
USA
WALLKE eBike $150 Coupon code WALLKECHAD01. Add to cart, fill out delivery page, and then add coupon code at payment page.

2021 X3 Pro in stock on sale for $1,849.89 w/code. Free shipping, no tax.
Typically ships UPS from California, US about 10 days or less arrival.
Hi JD, any idea if Wallke will send out a retrofit repair for the Speedometer issue, not working when coasting, or the WPas regen not working in 2021 models?
 

Curcutie

Member
Region
USA
Hi JD, any idea if Wallke will send out a retrofit repair for the Speedometer issue, not working when coasting, or the WPas regen not working in 2021 models?
Hey johnwebike, I spoke to op on Reddit. His bike seems to be normal and he got it in may. He has regen, a correct speedometer reading and the correct top speed. Therefore, I’m a little confused. Why was his bike given the old components but not ours. His bike just came in a little later than ours.
 

johnwebike

Member
Region
USA
Hey johnwebike, I spoke to op on Reddit. His bike seems to be normal and he got it in may. He has regen, a correct speedometer reading and the correct top speed. Therefore, I’m a little confused. Why was his bike given the old components but not ours. His bike just came in a little later than ours.


Hmmm.... interesting.... I wonder, did he buy his from Amazon or direct? Mine was direct from Wallke. Where did you get yours?
In any case, sounds like it wasn't a manufacturing change, does it?
If you could get a little more info from op on Reddit, maybd we could go to our "support" person and ask them... sounding more hopeful...
My support person name is Wolf. Who is yours, and has the Redit person had any issues?
also would be great if the person with the working bike would send us a photo of his motor inscription and controller id plate, so we could see what exactly was "substituted" on ours. We could ask for specific parts to repair ours. That may be a lot to ask, perhaps we should ask our support people at Wallke whats up.
 
Last edited:

johnwebike

Member
Region
USA
WALLKE eBike $150 Coupon code WALLKECHAD01. Add to cart, fill out delivery page, and then add coupon code at payment page.

2021 X3 Pro in stock on sale for $1,849.89 w/code. Free shipping, no tax.
Typically ships UPS from California, US about 10 days or less arrival.
JD are you a Wallke representative? Several of us are having some strange issues with the bikes we received in April order, delivered May. Can you help?
 

JDsplice

New Member
Region
USA
I am an Ambassidor which provides me/you with a coupon code and I will be posting some YouTube vids on my experience with WALLKE and my commuication with them as I have had various issues that I am in the middle of working with WALLKE to resolve. I also have to do further testing to find out the limits of the bike. I can confirm that coasting speedometer is working, but have to do more testing for the accuracy. I cannot confirm regenration and WALLKE has said that the May equipment is not compatable with regen braking. I am very busy at work leaving me with little time for the bike so I will try and test/share when I am not so busy. It also has been constantly raining and gloomy which makes for crappy vids. I am mostly working on upgrading some of the bike which I will cover in a full YT review. A lot of orders have to still come in and be installed.
 

johnwebike

Member
Region
USA
I am an Ambassidor which provides me/you with a coupon code and I will be posting some YouTube vids on my experience with WALLKE and my commuication with them as I have had various issues that I am in the middle of working with WALLKE to resolve. I also have to do further testing to find out the limits of the bike. I can confirm that coasting speedometer is working, but have to do more testing for the accuracy. I cannot confirm regenration and WALLKE has said that the May equipment is not compatable with regen braking. I am very busy at work leaving me with little time for the bike so I will try and test/share when I am not so busy. It also has been constantly raining and gloomy which makes for crappy vids. I am mostly working on upgrading some of the bike which I will cover in a full YT review. A lot of orders have to still come in and be installed.
Please post a youtube link.
 

johnwebike

Member
Region
USA
I am an Ambassidor which provides me/you with a coupon code and I will be posting some YouTube vids on my experience with WALLKE and my commuication with them as I have had various issues that I am in the middle of working with WALLKE to resolve. I also have to do further testing to find out the limits of the bike. I can confirm that coasting speedometer is working, but have to do more testing for the accuracy. I cannot confirm regenration and WALLKE has said that the May equipment is not compatable with regen braking. I am very busy at work leaving me with little time for the bike so I will try and test/share when I am not so busy. It also has been constantly raining and gloomy which makes for crappy vids. I am mostly working on upgrading some of the bike which I will cover in a full YT review. A lot of orders have to still come in and be installed.
If your speedo works coasting and while in PAS O,
Would you post a photo of your hub motor data plate, and your controller data plate?
Also, is there a speed sensor on the wheel or spokes? I would like to compare and maybe get Wallke to send me parts to make my speedometer functional. I am very curious about the speed comparison to a GPS in a phone as well.
My bike will not exceed 22mph with a 185lb rider on flat ground. And it is significantly weaker motor/controler than the same 750W Aventon Aventure bike my Father just got. I look forward to your post.
 

JDsplice

New Member
Region
USA
If your speedo works coasting and while in PAS O,
Would you post a photo of your hub motor data plate, and your controller data plate?
Also, is there a speed sensor on the wheel or spokes? I would like to compare and maybe get Wallke to send me parts to make my speedometer functional. I am very curious about the speed comparison to a GPS in a phone as well.
My bike will not exceed 22mph with a 185lb rider on flat ground. And it is significantly weaker motor/controler than the same 750W Aventon Aventure bike my Father just got. I look forward to your post.
Photo of Motor. I have to ask WALLKE if this is still an AKG motor or something else now as I googled the print and came up with no results.
Although I cannot directly help you with your issues. Here are some testing results:
Speedo works at any level PAS. Speed accuacy test seamed to be ok while riding and setting up on a tread mill which has a max of 10mph and the display is only off by 0.1. My tire setting is 28inch in Advence Settings.
I dont' have a pic of the controller and bare in mind that I think mine is defective as I have had several issues with it since day one. I am currently working with WALLKE to resolve them.
I have no idea where the speed sensor is as there is nothing obvious for me to find while I have been working on/testing the bike. I can only assume its part of the motor hub.
 

johnwebike

Member
Region
USA
Photo of Motor. I have to ask WALLKE if this is still an AKG motor or something else now as I googled the print and came up with no results.
Although I cannot directly help you with your issues. Here are some testing results:
Speedo works at any level PAS. Speed accuacy test seamed to be ok while riding and setting up on a tread mill which has a max of 10mph and the display is only off by 0.1. My tire setting is 28inch in Advence Settings.
I dont' have a pic of the controller and bare in mind that I think mine is defective as I have had several issues with it since day one. I am currently working with WALLKE to resolve them.
I have no idea where the speed sensor is as there is nothing obvious for me to find while I have been working on/testing the bike. I can only assume its part of the motor hub.
I think that may be an issue with my bike, the motor without regen wont power the display for speed. I am curious, when did you order and take delivery? I heard of one other person taking delivery after mine who has none of my problems. My Wallke rep, Wolf, says my speedometer is not supposed to work while coasting or in Pas 0. Lol.
They are not trying to fix my bike at this time and have stopped respinding to my emails. if you continue to ambassador for them, I wish you good luck.
 

johnwebike

Member
Region
USA
Photo of Motor. I have to ask WALLKE if this is still an AKG motor or something else now as I googled the print and came up with no results.
Although I cannot directly help you with your issues. Here are some testing results:
Speedo works at any level PAS. Speed accuacy test seamed to be ok while riding and setting up on a tread mill which has a max of 10mph and the display is only off by 0.1. My tire setting is 28inch in Advence Settings.
I dont' have a pic of the controller and bare in mind that I think mine is defective as I have had several issues with it since day one. I am currently working with WALLKE to resolve them.
I have no idea where the speed sensor is as there is nothing obvious for me to find while I have been working on/testing the bike. I can only assume its part of the motor hub.
Oh, I just looked at your pictures. My motor is the same. Thank you for the pic. Now im thinking Wallke switched the controller. Youd think they would just send the correct one though if its just that. Thanks for the photos. Love the treadmill!
I will video my speedo moving against a GPS on my bike and post later today to show my issues. Thanks again.