Firmware update on motor

900ss

New Member
Does Mission Control need a cell connection to work? I am considering updating my phone and will mount my old one to the handlebars if no cell connection is needed. Hmm, I guess if a cell connection IS needed, I could connect through the hotspot.
 

Rixtory

New Member
Region
USA
Got the update on motor done today on my Vado 5 SL. I asked what was in the new firmware and tech didn’t know other than to say a few bug fixes and minor tweaks. I don’t think Specialized wants a lot of detail out there for competitive reasons. A little surprised to see a brand new silver Turbo Vado 5 SL like mine next to a new Creo both unsold at my LBS. things starting free up a little.
Hmmm I saw those 2 bikes together as well a few week ago...Are you in Philly?
 

LBar

New Member
Region
USA
Wanted to give an update on this. I had my Vado sl 4.0 eq updated today at my dealer. I got the bike home and started a ride. The chain promptly jumped off the chain ring. Went back to the shop because the chain was stuck in between the motor housing and chain ring and I didn’t want to tear up the paint down there. They got it back on the chain ring and when I got home I started another ride and within a quarter mile it came off again. I rode this bike 250 miles or so with zero issues before the update. Now the chain has come off twice in less than a mile. Called the LBS back and they put in a message to Specialized. They think it could be the update. They also think Specialized could end up replacing the chain ring. Today was a long day needless to say. Anyone with this bike may want to wait before they update theirs.
I had the chain jump off the SL when I did a test ride recently. I thought it was because I downshifted too aggressively, but maybe I was wrong?