FIXED: How do you add rider power to Garmin on Specialized Creo SL?

kattanm

New Member
I see some of you have figured that out. I’ve searched the forum, etc., and can’t figure out how you are doing that. I have the Fake Channel set to Rider Power. My Garmin 830 sees what looks like a Creo Power Meter as a sensor, which I can connect to. But when I ride, power simply looks like about 100W or so no matter what I do on the pedals. Sorry if this has been answered, and I didn’t find the answer in my search.
 

NBS

Member
I tried to use the fake channel to show motor power and had the same issue. For rider power I just use the regular Garmin field for power that you will see as an option when you set up your Garmin data fields, where you set up the head unit for cadence, speed etc. There are a number of different power data fields you can choose (average, 3 second power, lap power etc). Seems to work fine although I am not sure how accurate the data is. It is not at all what I am used to seeing on my other bike with a Quark power meter.
 

kattanm

New Member
I tried to use the fake channel to show motor power and had the same issue. For rider power I just use the regular Garmin field for power that you will see as an option when you set up your Garmin data fields, where you set up the head unit for cadence, speed etc. There are a number of different power data fields you can choose (average, 3 second power, lap power etc). Seems to work fine although I am not sure how accurate the data is. It is not at all what I am used to seeing on my other bike with a Quark power meter.
Ok so I will just turn off the Fake Channel, connect Garmin to Creo power meter (as I did before)? Having the Fake Channel enabled is what's causing my problem?
 

Captain Slow

Well-Known Member
I had the same problem where it seemed to only report around 100 watts regardless. Then it started to report power levels that seemed correlated to my effort. I can't remember what I changed though, but it appears to be giving me correct readings now.
 

kattanm

New Member
Thanks everyone. They key is disabling the Fake Channel setting in Mission Control. In fact, the Creo manual should probably say "If you're using a Garmin, ignore this Fake Channel section."