Haibike SDuro (Yamaha), operate without display?

michaelbolton

New Member
yes.. patiently waiting for the led one to arrive. ridewill charges 50m dollars to ship to USA. BTW..I have holt melt glued the current one on for now.
Did the led model work? I'm looking to fix this with the better button . This display broke at the begining of a bike park day, and ruined the whole day for her.
 

33red

Member
I have a 2017 large rectangular display. I guess instead of a center installation i could go left and just turn it down or maybe installing some metal on the receivers might work? I have no clue, just brain storming.
 

Saru9999

Member
pretty much tried everything I could think of ... Rotated the display, rebuild the top and bottom section. Finally, glued the whole thing as a blob nd left all screws loose.. we will see. Its the big pain point with the 2016 models. I order the LED module bu the person I purchased it from did not ship it.
 

michaelbolton

New Member
pretty much tried everything I could think of ... Rotated the display, rebuild the top and bottom section. Finally, glued the whole thing as a blob nd left all screws loose.. we will see. Its the big pain point with the 2016 models. I order the LED module bu the person I purchased it from did not ship it.

I called haibike north America and spoke with someone who sent the parts to me in three days. The screen is not officially supported for this bike, but it does work. He had to order the part from a different bike. I just got the led screen in today. I'll update this thread with some results. By the way, do you have the black button symbols or white button symbols on your remote? I've heard the white font is an older model that doesn't support the led remote swap! This is a 2017 haibike sduro allmtn 5.0 and I've come to learn that they used the 2016 model Yamaha pw LCD with black buttons on the remote. I hear the 2015 and below Yamaha pw has the white buttons. Can anyone confirm that?
 
Last edited:

33red

Member
I called haibike north America and spoke with someone who sent the parts to me in three days. The screen is not officially supported for this bike, but it does work. He had to order the part from a different bike. I just got the led screen in today. I'll update this thread with some results. By the way, do you have the black button symbols or white button symbols on your remote? I've heard the white font is an older model that doesn't support the led remote swap! This is a 2017 haibike sduro allmtn 5.0 and I've come to learn that they used the 2016 model Yamaha pw LCD with black buttons on the remote. I hear the 2015 and below Yamaha pw has the white buttons. Can anyone confirm that?

I recently bought an unsold 2017 Haibike/Yamaha. Looking under the frame it mentions built in 2016 but model 2017. I have no white buttons, this is the large rectangular screen. My bike is SDuro Hard seven 6.0. I read we can see how many cycles/charges(full) have been done by pushing/holding the battery buton, where is that buton? I allways charge battery still on bike. Now 3,380 km trouble free. Thanks
 

Saru9999

Member
Ok so i got my money back ( love paypal) so I can try again. Mine is a 2016 with black buttons. so based on your post, i should be able to put on a LED module?.. interesting to see what your experience is with the LED display.. Hopefully, I can order one from Haibike as well?
 

Saru9999

Member
explains it all.
 

Attachments

  • haibike.png
    haibike.png
    197.5 KB · Views: 379

Saru9999

Member
Ok.. I'm going to order a LED disply from ridewill.. Who else wants one.. price will be what I pay + your share of the freight.. ( 50 odd euro) (in other words, its a group buy)
 

michaelbolton

New Member
It works perfectly with the led display. I had to remove the bolts that hold the first two motor bolts and pivot the motor down to get to the plug. I replaced the cable through the frame, mounted up the new remote and it turned right on and worked perfectly!
 

Saru9999

Member
So I finally got it. Runs. Sort of wondering if I’m not getting full power at low cadance. Could just be me being off the bike for a month.
 

Attachments

  • C2341582-4D4A-4087-8017-C86C08767420.jpeg
    C2341582-4D4A-4087-8017-C86C08767420.jpeg
    109.9 KB · Views: 271

Saru9999

Member
pretty sure the mapping is very different between LCD and LED.. High does seem as high. normal seems higher and eco is unusable. the range is down ( about 2 miles less on a 12 mile ride). a lot more reliable though. so basically I have to be content
 

Jsb

New Member
My girlfriend had a minor spill at the bike park and broke the display mount for the second time in two months! I'm capable of resoldering the cable IF someone can send me a picture of the inside of their mount so I can make sure I am getting the order right.
The Diagram posted here earlier looks like Black - Orange - Brown - Red, but I'm not sure of the orientation. Thanks!
Hi Micheal
I had exactly the same problem today, went over the handlebars and sheared the bracket off. Now staring at 4 wires wondering in what order to solder them.
I know this thread is quite old but I was wondering if you got the answer to the question?
Joe
 

Sakkiediekok

New Member
Region
Other
Hi guys, I am new to the forum, I read through all you posts but I qm still uncertain whether the 2015 Sduro is compatible with the led display. Have any of you tried to install one on this modelyear with success, My display was stolen off my bike and would prefer replacing it with the led model