Hello from the Fens with a Giant water issue

Hi thank you for letting me join.
I have a Giant Explore E+2 hybrid, I have covered 1400 miles since November last year. In heavy rain or after washing I find that water gets in to the pull apart connector from the handlebar switch.
Which then switches itself on and won't switch off again, unless the battery is removed.
I have tried heat shrink tube over the join which didn't work, it actually made it worse 😥. Has anyone tried anything else to stop the water getting in?
20200422_090626.jpg
 

pmcdonald

Active Member
Hi thank you for letting me join.
I have a Giant Explore E+2 hybrid, I have covered 1400 miles since November last year. In heavy rain or after washing I find that water gets in to the pull apart connector from the handlebar switch.
Which then switches itself on and won't switch off again, unless the battery is removed.
I have tried heat shrink tube over the join which didn't work, it actually made it worse 😥. Has anyone tried anything else to stop the water getting in? View attachment 53156
Welcome! Nice looking ride. Mine came in blue accents but I like the red. It looks faster!

Sorry to hear about your water issues. It's a known problem with Giant controllers. A few members here have had theirs replaced under warranty. I would recommend taking yours to your dealer for a claim. And perhaps carry a sandwich bag or two and some rubber bands in the mean time?

There's an enthusiastic Giant subforum here you can throw your Giant specific questions at: https://electricbikereview.com/forums/forum/giant/