Help please --- intermittent power problem

David Morgan

New Member
Hi


I was wondering if anyone can help, I bought a Turbo Levo 8 months ago since then its had a new battery, wiring loom, sensor and new motor (which it totally packed in)


The bike is still got a intermittent power problem. The bike has been in and out my local dealer over the last 8 months to try and resolve but no joy.


The bike gets ridden in the Scottish weather mainly rain, all the connectors have been greased


I love this bike and I just want it to work any help would be much appreciated


Thanks


David
 

David Morgan

New Member
Hi


I was wondering if anyone can help, I bought a Turbo Levo 8 months ago since then its had a new battery, wiring loom, sensor and new motor ( Old motor which it totally packed in)


The bike is still got a intermittent power problem. The bike has been in and out my local dealer over the last 8 months to try and resolve but no joy.


The bike gets ridden in the Scottish weather mainly rain, all the connectors have been greased


I love this bike and I just want it to work any help would be much appreciated


Thanks


David
 

Ann M.

Well-Known Member
Greased? The connectors? Please clarify because you don't grease connectors. What material are you using, please! We want to help. :)
 

Ann M.

Well-Known Member
Silicone dielectric grease? If you're using a dielectric grease that should improve the connectivity, then this may still be a wiring harness issue. I'd look closely at two connection points: the battery & it's mount and the console where it connects. Both of those are vulnerable spots.