HELP, PLESE! KT-LCD8HU setup

Nino

New Member
Region
Europe
City
Lovran
My friend has the wheelchair assist device (Triride hp16) and the bldc controller has burned.
It works like as an electric scooter.

I ordered the new controller KT48ZWSRL-GP06.
IMG_20210201_201423.jpg


Connected all and the problem is that the motor is spinning perfectly in assist "walk" mode by holding the down arrow but with the throttle nothing happens.
Checked the voltage of the throttle and there is 4.5 V.
Between (-) and signal wire is 2.2V and by turning the throttle, voltage is rising to 4.5V.
These initial 2.2VDC are a little bit strange, shouldn't be almost 0?

The new KT controller has 6 wires for the Hall sensor, the motor has 5 wires and the 6th wire white (speed sensor) I didn't connect.
Could that be a problem? Will the controller operate without the speed sensor?

Also. I checked the KT-LCD8HU setup and everything seems fine.
IMG_20210201_190551.jpg


Could it be that some of the parameters are wrong?

The parameter P1 motor characteristic - how can I be sure that this parameter is correct?
How can I be sure which motor do I have?
In manual I only found that it is 1500W motor.

Please give me some advice! :)
 

harryS

Well-Known Member
P2 =0 if you don't have a wheel speed sensor but it should not impede the motor if set wrong.

Try C4 = 0, for the throttle always on. see my later comment

I thought the inital throttle voltage is like 1.x volts, As a another test of the controller motor wires, if you remove the throttle connector, and put a diode between +5 and throttle input, the motor should run full speed.

Fast Wheelchair bike. New to me.
 
Last edited:

EMGX

Well-Known Member
It is curious to me why controllers don't come with programming instructions.
Bolton has a review of programming. He explains the different settings but not all of the options within a setting when he explains the KT-LCD3 so don't skip that part.

Here is another less succinct explanation, this one does give a little more detail regarding some of the options within a setting.


For a geared hub motor like mine the P1 setting is the product of the internal gear reduction (4.5:1 in my case) times the number of the magnet poles in the motor (20 in my case, so for me P1 is set at 90).

FWIW for my ebike kit the throttle only works if an assist level is chosen, doesn't work on setting zero.

Following is for my bike kit, don't know if it would apply to your application
C1 is for PAS assist and maybe sensitivity, not sure what function it would have for a wheelchair
C2 is for phase 0 is square wave, other settings for sine wave - aren't most controllers square wave? if so maybe it should be set at 0?
C4 0 looks right for normal throttle function, other settings I think require at least initial PAS input for the throttle to work.
 
Last edited:

harryS

Well-Known Member
I was wrong on my initial suggestion,
Set C4 = 3, if you want the throttle always enabled,

Otherwise, as mentioned above, it is only active if you have picked a non-zero pedal assist level. Since this is wheel-chair, there probably is no pedal assist, and you may have ignored bumping up to PAS 1, or higher.
 

legsofbeer

Active Member
I have that display, and a similar model controller. It looks like you have p3, p4, c4 set correctly to enable the throttle. But I have managed to recreate your symptoms, where "walk mode" works, but throttle and PAS do not: I changed the P2 value away from "5", which is what works with my motor. For instance, on P2=1 or P2=0, walk mode works, but throttle and PAS do not. So I suggest you try all 7 P2 values and see if any of those activate your motor via throttle.

From my notes on bolton's video:

p1: just set to 100 for 750w bafang
p2: number of magnets "try 5, only 7 settings"
p3: "0" caps throttle to PAS level, "1" uncaps
p4: "0" throttle always on, "1" disables from stop

c4: throttle options "0" always on, "1" limited to 6kph until pedalling (note that c4 is matrixed with p4. But p4=0 and c4=0 means you can throttle from a dead stop, at least that's how my bike works)

other ideas:

Here's one silly idea, get the chair moving with the down button, then try applying throttle.

But, since I can't see any likely problem with your display configuration, maybe there's a hardware issue? Ground loop or fault with the throttle, or maybe the wires are backwards so the controller is seeing negative voltage? I don't have an answer for the question of whether the controller requires a speed sensor reading to activate the motor--I would assume that if it did, it would show a fault code on startup. But it is fully capable of throttling up from a speed of zero, so one would think a missing speed sensor wouldn't matter.
 
Last edited:

legsofbeer

Active Member
Between (-) and signal wire is 2.2V and by turning the throttle, voltage is rising to 4.5V.
These initial 2.2VDC are a little bit strange, shouldn't be almost 0?
I don't think so. You don't want the throttle false activating on signal noise around 0 volts. So a range gap before activation makes sense.
 

Nino

New Member
Region
Europe
City
Lovran
Thank you for the replies.

I tried with different setup, unfortunately without success.

Tried all combinations with the P2
P3 - 0 - read about P3 in the KT-LCD8 manual and it is not so clear for me for what it stands for....
P4 - 0 - I think P4 must be 0 (with C4-0) because there is no PAS sensor. As this is for wheelchair it uses only throttle.

As there is no PAS sensor, how should the C1 be set up?

@harryS will try the throttle with the diode this weekend.

Maybe I need to start from the P1, because I'm not sure if the value 192 is correct. I don't know what was before with the old controller.
Could it happened that the LCD8HU parameters changed on the default settings when I changed the controller or if the LCD was longer time without battery?

@legsofbeer could you please, just for test, change P1 on some random number and check if you have mine symptoms?
 

AHicks

Well-Known Member
Region
USA
City
Snow Bird - Summer S.E. Michigan, Winter Gulf Coast North Central Fl.
First, be VERY careful regarding the C values, and the P values. I'm ALWAYS screwing myself getting them crossed.

P3 is about PAS type. Speed based vs. power based. Set it to 1 and forget it. It should work on 0 or 1, but pretty sure you will like 1 better (smoother).

P4 must be set to 0 to have a throttle full time - as in the throttle will work from a standstill. Set to 1 the bike will need to be moving before the throttle works.

Ignore C1 if you aren't going to use PAS

Do not be shy of doing a reset (C10=Y) if you aren't sure of where you are at because of too many changes.
 
Last edited:

legsofbeer

Active Member
change P1 on some random number and check if you have mine symptoms?
I did, and on any value between 24 and 255 (normal value for me is 100), both throttle and PAS work. If I try to set it below 24 for some reason when I power cycle the bike and bring up the config screen again, it has changed to 87.

The manual says: "P1 is motor characteristic parameter setting, P1 = motor gear reduction ratio×number of rotor magnet pieces, just rounding if there’s any decimal."

My geared hub has 5x gear reduction, and apparently 20 magnets, so the value is 100. The Trirides appear to be a 1500w direct drive motor, so the "gear reduction" would be "1", and the P1 value should be the motor magnet count. You might try likely values like 12, 20, 24, 36.
 

harryS

Well-Known Member
P1 is supposed to only affect the speedometer, but it does affect the motor function. When you go to low, it does reset to about 24. Try 44 or 88 until you get the motor running. Then tweak it til the spedometer is more or less accurate. I have 8:1 gear reduction motors and my P1 is 208-220.

If you set C10 = y, you get default.

My settings
P1=210
P2=1
P3=1 Gives max throttle in all PAS levels
P4=0 Throttle works w/o needing the oedals to spin
P5=15

C1=1 Defines magnets in PAS senspr
C2=0 Default value. Keep it here
C3=1 Power-on level for PAS . You should use 1. I use 0.
C4=3 for throttle on in pAS 0
C5=10
C6=4
C7=0
C8=0
C9=0 Password disable. Never enable it. You'll forget the password.
C10=n
C11=0
C12=4
C13=0
C14=3
 
Last edited: