LBS is unable to update firmware on Vado 4.0

Mando Dave

New Member
Region
USA
My LBS is unable to update the firmware on my Vodo 4.0 Ltd. They tried at least 10 times, used different cables. Has any one else experienced this and what was the solution. Thanks
 

Attachments

  • Screenshot_20210502-164825.jpg
    Screenshot_20210502-164825.jpg
    46.3 KB · Views: 32

Art Deco

Well-Known Member
Region
USA
City
Selinsgrove
My LBS is unable to update the firmware on my Vodo 4.0 Ltd. They tried at least 10 times, used different cables. Has any one else experienced this and what was the solution. Thanks
Since noone has replied, I will just to keep your thread alive so someone knowledgeable can see it and maybe help. I have not had this problem, but my LBS mentioned that he has escalated an electronic issue to a regional Specialized representative before, so there is a process to address these issues through Specialized. IDK how it works, but the dealer should know.
 

Quinncy

New Member
I need to get that update too. Taking the bike in today. Stay tuned I'll let you know if I get it updated. I'm not holding my breath as this bike has been nothing but issues. Fingers crossed.
 

Mando Dave

New Member
Region
USA
Update: Not resolved yet. I contacted Specialized and they got back to me very quickly. (I have been impressed with their Customer Service). They resounded
"I have not heard of this issue. That is certainly strange.
I just ran some diagnostics on your bike and it looks like the system is rejecting the updates. I contacted my turbo tech and they want the shop to submit a claim to our service department. They will be able to help the shop from there!"

My LBS has been in contact with Specialized and are ready to try a few things. Me, I am waiting for crappy weather so I can be with out the bike for a couple days.

I will keep you posted
 

Quinncy

New Member
Update: Not resolved yet. I contacted Specialized and they got back to me very quickly. (I have been impressed with their Customer Service). They resounded
"I have not heard of this issue. That is certainly strange.
I just ran some diagnostics on your bike and it looks like the system is rejecting the updates. I contacted my turbo tech and they want the shop to submit a claim to our service department. They will be able to help the shop from there!"

My LBS has been in contact with Specialized and are ready to try a few things. Me, I am waiting for crappy weather so I can be with out the bike for a couple days.

I will keep you poste
 

GuruUno

Well-Known Member
Several months ago I stopped by my dealer to update the firmware for the motor and battery, and he said only the motor was doable.....(Vado 5.0), that was then, not sure about now. He even took the battery out/off of the bike with no updated posssible.
 

Mr. Max

Active Member
This thread got me curious, so I just checked my 2020 Vado 4. All aspects of the firmware are up to date. I remember the last update was for the display. The LBS did it easily and it just took a couple of minutes. I'm lucky, my LBS doesn't mind me coming in whenever there's firmware update, so I always bring it in as soon as I see the notice. I probably check once a month. There's never been a problem with any firmware update. At least so far! I'm not sure what to tell you? For me, there's never been a problem and there isn't one now.
 

Mando Dave

New Member
Region
USA
Here is the latest - There was a lot of weird stuff going on during diagnostics and they are going to replace my bike's motor. We will see how that goes.