LCD Display

meriweather

New Member
Region
USA
My Wallke X3 Pro LCD Display won't turn on. I press the Power On/Off Button and the screen remains blank. As far as I can tell, the battery is fully charged and I have reseated it. I've also checked the cable connections and they seem to be all right. The bike is only 6 months old.
I’ve contacted Wallke but have not heard back from them.
Is there anything that I can do to get my LCD Display back on?
Have there been any issues with the LCD Display doing this or, is it the Controller that’s the problem?
 

Max Black

Active Member
Region
USA
I can see that you are in touch with Wolf and we are working on your case.

Need to check:
1. Battery voltage
2. Display cable
3. Power connection cable

Test:
Please try turning on the display while charging the battery. If the bike still can't be turned on while charging, please open the battery compartment and check power connections.
If the bike can't be turned on while charging, please test your battery voltage.

If there is loose connections, corrosion or broken cable, the Wallke X3 Pro LCD Display won't turn on, when press the Power On/Off button and the screen remains blank.
Please verified wheter the battery terminal/display cable got a loose connection/broken.

How to test the battery voltage:

How to test the battery voltage:

Remember to share the test result with Wallke service team.
 

meriweather

New Member
Region
USA
Thanks Max for you reply.
I have indeed been in contact with Wallke and they gave me instructions on what I needed to do to test the battery. In following their instructions, I found what the problem was. One of the terminals on the battery broke. With the bike folded in half, it must have shifted and hit something during transport.
The photograph should explain it…

I have ordered a new battery and will eventually buy a new Battery Head for my broken one. They have given me instructions on how to replace that battery head.
Hopefully, that will take care of everything.
 

Attachments

  • Battery Damage.jpg
    Battery Damage.jpg
    663.4 KB · Views: 40