Lights in Haibike Trekking Pro S

HeikkiM

New Member
HI!

I have haibike trekking Pro S (2016) pedelec. The bike is great but there is one thing I have not been able to live with.

The lights.

It seems that the front light is ON all the time and the rear light is OFF. There is light switch in the Nyon computer, but it seems that nothing happens when pushing it.

I have tried to contact the dealer and the Haibike, but I haven´t got any answer.

Can someone here help me?

Thank you very much in advance!
 

Jim S

New Member
HI!

I have haibike trekking Pro S (2016) pedelec. The bike is great but there is one thing I have not been able to live with.

The lights.

It seems that the front light is ON all the time and the rear light is OFF. There is light switch in the Nyon computer, but it seems that nothing happens when pushing it.

I have tried to contact the dealer and the Haibike, but I haven´t got any answer.

Can someone here help me?

Thank you very much in advance!
I had a 2014 version and had a similar problem. I resolved the switch issue by using the lights in the always on position, since the switches were troublesome to use. I never did get the light button on the display to operate the lights. I used the handlebar switch. It seemed to need a few second hold to change what appeared to be a 3 position switch as you kind of discover. There was a 1.) both lights off - 2.) both lights on - 3.) taillight on. I never saw a headlight only on position. At one point the switch was showing the blue light illumination when both lights were on, and it seemed like I had figured it out or..., but that was short lived (maybe it wasn't dark enough).
Since you have to be moving to see the change, I originally pointed the light at the cable to detect when it was on... but eventually as I said, I couldn't get the switch to be consistent in any way so I got it to the on position and never used either switch thereafter. I also asked the shop where I purchased and they wanted me to bring it in, but being quite a distance I figured I could push a button as well anyone, and it wasn't simply a pushing issue. I think the arrows were designed to be for the individual lights but it appeared that the up arrow cycled all options and the down arrow did the taillight only. I know I originally thought the lights would be on and only the tail light would be lit. (As I recall reading the included single sheet of paper to describe the light switch operation was uninformative.)
Anyway try holding the forward arrow in for a up to 4 seconds (up to a couple times). I think that should be the correct switch for the front light.