mini battery holder broken at the bottom

vincent

Well-Known Member
my mini battery has not seemed to sit right in the holder since i got it

it sits about 1/2 in or a little more above the plastic thing on the bottom, looks like it should slide down into that but it doesnt
we also had 3 complete power cut outs on a dirt road that was not really that bumpy or bad, like the battery is losing connection

on mine the battery slides in and sits above the plastic piece and then i have to lift it a little to lock it, so it is even further out of the bottom slot

can anyone else look at theirs and let me know how it looks
will try to post a pic of mine here

also the black plastic piece on the bottom cracked the first 10 minutes we rode it
anyone else having these issues?

wont go into my responses from rad power right now but not overly happy
seems i email 4 questions and get a reply to 1 question 3 days later
and back and forth




IMG_1278.JPG
IMG_1271.JPG
IMG_1272.JPG
 

mbirds

Member
Bummer man. Try to get them on the phone. With my controller they called me back and I explained and then emailed a picture. I tried email at first but it took too long.
 

grench

Well-Known Member
my mini battery has not seemed to sit right in the holder since i got it

it sits about 1/2 in or a little more above the plastic thing on the bottom, looks like it should slide down into that but it doesnt
we also had 3 complete power cut outs on a dirt road that was not really that bumpy or bad, like the battery is losing connection

on mine the battery slides in and sits above the plastic piece and then i have to lift it a little to lock it, so it is even further out of the bottom slot

can anyone else look at theirs and let me know how it looks
will try to post a pic of mine here

also the black plastic piece on the bottom cracked the first 10 minutes we rode it
anyone else having these issues?

wont go into my responses from rad power right now but not overly happy
seems i email 4 questions and get a reply to 1 question 3 days later
and back and forth




View attachment 9488 View attachment 9491 View attachment 9494
@vincent any chance the female poles on the battery are shifted to one side? When I blow up the picture of the male end it looks like one side on one of the poles is worn. The battery probably has two sides like a close pin...the pole should slide between the sides on the battery. Just a thought??
You may also look for impact points on both the bike and the battery. There may be a worn spot on the plastic which would indicate a point of interference??
 

vincent

Well-Known Member
hey grench

just looked it over and it all looks right
cannot really tell where the problem is

can others tell me if their mini batteries fit flush on the bottom or have a gap like mine does?
in my mind the gap is the problem... that it is not seated properly but looking at the way it is made the metal piece the battery slides down etc all seems to be correct

nothing looks bent or messed up, the battery just sits high
the thing is in order to lock it at the top i have to lift it even higher which seems weird

i sent these pics about the battery holder issues and explanations to rad and questions about how my pas is working

this is the reply i got
--------------

PAS level 1 was meant to be very gentle to help out in crowded areas. It uses about 40-50 watts and has a top speed of 2-3 mph. If the watts go below 50 or so then they won't show up on the display.

PAS 2 should be a little bit more power full at about 100 watts and have a top speed of 3-6 mph

PAS 3 will definitely have some power behind it so that sounds normal. Let me know if PAS level 1 and 2 seem to be working according to what I described above or not.

--------------

now i am completely stumped because sang lists totally different numbers for his radmini in pas levels, watts, mph????
i kind of bought the mini off the numbers sang gave us and now rad is saying they are these above.... the numbers above seem useless,, sangs numbers looked useful to me
dont understand if this is a bafang problem with programming and rad power has no control over it or they are asking for controllers that work like this

what is the point of having level 1 at 40watts to 2-3 mph, dont think i can even roll the bike that slow walking beside it
so level 1 might as well not be there at all unless it is walk mode maybe..

and 100 watts for level 2??? and then big jump to 3
this is crazy and i dont even know what to think

honestly if i wouldnt lose $400 shipping it back i would return the bike
love the form factor of the 20 inch fat bike but for 1700 having a useless pas i would have paid 1300 or whatever it is for the voltbike mariner and just used throttle

which also is not working or sucks on the mini
and it has nothing to do with being a 20 inch bike as someone else suggested , i have 2 prodeco mariners- 20 inch that work perfectly fine with smooth throttles at any speed

there is definitely something wrong with this bike but the numbers given for a correctly working pas from them really upset me and i am not happy

i do need to call rad power and try to get this resolved but have a job that pays for all these bikes and havent had time lol

will definitely post back the results once i do
 

dan heath

New Member
my mini battery has not seemed to sit right in the holder since i got it

it sits about 1/2 in or a little more above the plastic thing on the bottom, looks like it should slide down into that but it doesnt
we also had 3 complete power cut outs on a dirt road that was not really that bumpy or bad, like the battery is losing connection

on mine the battery slides in and sits above the plastic piece and then i have to lift it a little to lock it, so it is even further out of the bottom slot

can anyone else look at theirs and let me know how it looks
will try to post a pic of mine here

also the black plastic piece on the bottom cracked the first 10 minutes we rode it
anyone else having these issues?

wont go into my responses from rad power right now but not overly happy
seems i email 4 questions and get a reply to 1 question 3 days later
and back and forth




View attachment 9488 View attachment 9491 View attachment 9494
I have the same issue at 90 miles but the battery seats properly
Rad service said they would replace it but its been five days
175 miles on it now
 

Attachments

hey grench

--------------

PAS level 1 was meant to be very gentle to help out in crowded areas. It uses about 40-50 watts and has a top speed of 2-3 mph. If the watts go below 50 or so then they won't show up on the display.

PAS 2 should be a little bit more power full at about 100 watts and have a top speed of 3-6 mph

PAS 3 will definitely have some power behind it so that sounds normal. Let me know if PAS level 1 and 2 seem to be working according to what I described above or not.

--------------

now i am completely stumped because sang lists totally different numbers for his radmini in pas levels, watts, mph????
i kind of bought the mini off the numbers sang gave us and now rad is saying they are these above.... the numbers above seem useless,, sangs numbers looked useful to me
dont understand if this is a bafang problem with programming and rad power has no control over it or they are asking for controllers that work like this

what is the point of having level 1 at 40watts to 2-3 mph, dont think i can even roll the bike that slow walking beside it
so level 1 might as well not be there at all unless it is walk mode maybe..

and 100 watts for level 2??? and then big jump to 3
this is crazy and i dont even know what to think
Hey Vincent,

That really sucks about the battery holder. Mine is holding up, I ride on a dirt fire road, but nothing really too bumpy.


Yeah, RPB's quoted PAS-Speeds are very different from my experience with my RadMini

Here are my #'s from the other thread. These were recorded on the same flatish piece of road...there is a very very slight incline, that you only notice on a heavy bike.

While riding with some effort in pedaling to maintain speed:
  • PAS - Approx MPH -- Watt range that displayed
  • 1 8.6mph 80-160w
  • 2 11.5mph 180-260w
  • 3 14.5mph 300-540w
  • 4 18mph 400-750w
  • 5 20.5.mph 540+-
From a stopped with cadence (no real pedal effort) to get to PAS level max speed
  • PAS 1
    • From 0-8mph: will ramp @ about 2-3mph to 300w+- (it can go a bit over, but generally tries to stay in this range for all of the PAS levels except 5, which will give you all 750w)
  • PAS 2
    • From 0-11mph: will ramp @ about 2-3mph to 400w+-
  • PAS 3
    • From 0-15mph: will ramp @ about 2-3mph to 500w+-
  • PAS 4
    • From 0-17mph: will ramp @ about 2-3mph to 600w+-
  • PAS 5
    • From 0-20mph: will ramp @ about 2-3mph to 750w

I blew up my headlight (the headlight wasn't lit, and I wiggled wire while on and 'poof'), RPB sent me a headlight, and we traced it to the controller... so they sent me a controller, but there's no way I want 3mph to be my pas 1 top speed. I would definitely fall over @ 3mph...I don't think that's the right #.

I attached a pic of how my RadMini battery sits.



Any other RadMini owners see similar #s? did I get a mutant bike?... I'm almost afraid to try the new controller...


Sang
 

Attachments

vincent

Well-Known Member
interesting your battery sits WAY closer to the bottom than mine
mine was cracked the first 10 minutes or maybe it even came that way

i sent pics of the battery in the holder and out showing the cracking to rad power and no response on that yet

hate to say this but i am under the impression that the mini controller has been changed or programmed different a few times since it first came out, so good chance the new one you got is different...
anxious to see how it does for you, please let us know

they say that level 1 assist at 50 watts, this guy today said 50-100, but anything under 50 the display does not register, do think i am getting a little boost in 1
not sure how long it last because the display always reads 0 in level 1
and level 2 for me today- when the bike was working- was maybe anywhere from 75-200/225
i can live with these numbers , it seems ok when it is working, but it is erratic
still would like to have pas numbers like you have sang but thinking at this point it is a pipe dream

today mine kept pulling error code 30- abnormal communication - all day while i was trying to get specific numbers for rad power on the pas and finally that is all it would do, so not working at all now
tried with and without throttle button pushed in and no change..

they think it is unlikely it has anything to do with how the battery is seating..
told me to check all the connections


just did that and they all seemed tight, dry and pins good etc
but i took them all apart anyway and put them back together, will ride it tomorrow and see what it does

also the front end started creaking and squeaking badly, took it to my lbs today and they tightened some stuff but nothing stopped it, finally lubed the folding part of the latch and it seems to have stopped

love the 20 inch fat bike platform but not loving this on a new bike with one ride and 36 miles
 

vincent

Well-Known Member
update on mini issues

took all the connections apart and checked them last nite, all seem dry , fine and tight when connected

rode the mini and same thing, immediately pulls error code 30

put in another email to radpower and will post on their response/suggestions etc

i did not open the controller box last nite but did a few days ago when the pas was acting erratic and all the plugs looked good and tight
 

vincent

Well-Known Member
update on my mini

rad power is sending me a new controller, display and throttle plus connector wires for all of this

not sure what is wrong but it still always has error 30

will keep this up to date on what solves it etc
 
Hi Vincent,

Please don't hesitate to reach back out to support if you have any follow up questions! They will make sure this is all corrected and you get back out riding if not already!
 

vincent

Well-Known Member
hey mike

thanks scott sent me the controller, display etc last week
i have just been too busy to get it all swapped

i did have problems trying to feed the controller plug to the motor through the case hole so just decided to have my bike shop do it

the mini should be back on the road tuesday...

appreciate you checking in
 

Thom473

Member
My battery sits above the rest as well. enough room for a small flat screwdriver blade. It is actually nice to be able to pry the battery up a scoch when I push it too far down.