“Motor Error” message and funny goings on

I’ve seen a few posts on here from people saying they get “motor error” from time to time and like me turning the bike off and on again resolves it. Well it didn’t when it happened again the other day. And much more alarmingly the bike took off entirely on its own with me running alongside it trying to stop it! Very dangerous. The dealer had a look and discovered that the battery was running an old software version and the motor a new one which may have been clashing with each other. Only time will tell if it’s worked but if it happens to you, get them to check all your software versions.
 
Currently, Mission Control allows checking if the bike software is up to date. Hope that helps.
The software for the motor but not the software for the battery so not really. The dealer said it wasn’t initially obvious when he looked but he had to go way back in the history of the battery to discover it. Something none of us can do without the dealer diagnostic software. I had no idea that both the motor and battery had their own software versions and Mission Control doesn’t help with that at all.
Apparently it also bought up another warning message to pass to customers - never charge with the battery turned on. I don’t but some might.
 

GuruUno

Active Member
I know a while ago there were some updates, do we have any type of running database as to what revisions are for each the motor and the battery for the Vado(s) and Como(s)?
Only as because I too today got a "surge while standing at the light waiting for it to change. Not drastic, but concerning enough to want to validate that t's all up to snuff.
 

Stefan Mikes

Well-Known Member
The software for the motor but not the software for the battery so not really. The dealer said it wasn’t initially obvious when he looked but he had to go way back in the history of the battery to discover it. Something none of us can do without the dealer diagnostic software. I had no idea that both the motor and battery had their own software versions and Mission Control doesn’t help with that at all.
Apparently it also bought up another warning message to pass to customers - never charge with the battery turned on. I don’t but some might.
The latest Mission Control shows the software version with possible updates for:
  • Motor
  • Battery
  • Display
Charging the battery when it had been on does not pose problems for me, on my Vado. The controller switches the battery into the charging mode. The display reads "Charging" and even gives the current battery %.