Motor won't rotate after hot plugging battery to controller

puffadder

New Member
Hi,

So I got a bicycle wheel with hub motor and a controller from china (along with other required parts like the throttle). I hooked everything up together and it was working nicely.

However, yesterday I plugged in the connectors from battery while the ignition switch connected to the controller was ON and there was a big spark at the battery connector of the controller.

Since then, the motor runs but doesn't turn the wheel. In fact, the wheel rotates very slowly in the opposite direction!

Things I have tested:

- The motor rotates freely when rotated by hand.
- Hall sensors: I verified that the hall sensors of the motors still switch between 0 and 4.5 V upon rotating the motor
- I measured AC voltage across the motor connectors from the controller and I get ~18 V (my motor is 24V 250W)
- Upon removing the hall sensor input, same behavior i.e. motor rotates super slowly in the opposite direction.

I am suspecting that something in the controller got fried and am trying to ascertain what exactly did.

Any suggestions on where I should look?

Cheers!
 
Your controller sounds fried. Sounds like one of the 3 phase circuits is bad. Probably one of the power mosfets gave up the ghost. This will cause the behavior you stated. Not sure how hot plugging caused this, but your motor is most likely fine.

 

Ann M.

Well-Known Member
Most likely one of the components on the controller board was on the verge of failing to begin with, not really rated to handle the power incoming. Not uncommon with some iffy inexpensive controllers. Find a better quality controller and keep going.
 

JoePah

Well-Known Member
My Samsung TV stopped turning on after a while and thru on linet forums found out the power board swelled capacitors were the culprit.. Yep.. Had someone replace 3 caps and it's been fine since.

NOT suggesting my TV problems have anything to do with your controller, except that a physical inspection takes only a few minutes. Functional Electric tests takes a little more research
Take apart the controller and look for swelled caps, burned out MOSFETS, or any signs of component damage.
 

Ann M.

Well-Known Member
Yep, those components are generally the culprits, @JoePah however, many ebike controllers are sealed with a waterproof resin making it difficult to impossible to replace individual components. Another problem point can be too much amperage coming through wires causing wires to melt together. Sometimes replacing the bad wiring fixes the issue. The mosfets in the motor and the contactor in the motor core can be replaced if you have the tools to pull the cover.
 

puffadder

New Member
Thanks for your insights folks!

I had posted the same question on another forum and a guy suggested that I connect the self-learning wires of my controller once and see if it works. That totally did the trick for me!
The thread is here: https://endless-sphere.com/forums/viewtopic.php?f=2&t=81285&p=1196493#p1196493
I'm still trying to understand why the controller suddenly forgot how to rotate the motor or what self-learning does.

Also, I tried to take apart the controller but some of the screws have glue on the other end and the waterproof resin also made life difficult. I figured that I had no other way of opening the controller than to cut it open so decided to order a new controller instead. That was before the aforementioned suggestion worked for me.