My City Commuter (Black) Has "Super Powers"

awillis858

New Member
No seriously.....I have something going on with my Controller (I think) where the bike is running super fast despite hardly applying any pressure on the pedals from my end. I'm 3 blocks ahead of my wife at all times! And she hates it when I run off and leave her. I don't try to, but the bike seems to have a mind of its own. LET'S GO FAST!

As background, I'm running all standard factory settings (PAL "On", Torque Sensor "On", Speed = 20.4 mph, etc.) I also typically ride in PAL "2", use limited throttle (only taking off when stopped at an intersection), and use my mechanical gears religiously.

Lately, I've noticed that no matter high lightly I touch the pedals, the bike wants to BLAST OFF and quickly speed up to the 20-21 mph range. It feels like I'm in PAL "5" all the time when I'm only in "2". I'm also starting to see the assist level readout (bars at the top left of the computer display) always displaying 3-4 bars indicating a high level of assistance from the battery (again, this is when I'm barely touching the pedals). Most frustrating, I'm now draining my battery prematurely (dropping the first bar at 10-11 miles - used to be 16-18 with a total range of 40-45)

My local Dealer contacted Pededgo and thought it was a faulty Controller. He replaced it. Same issue still happening.

Has anyone experienced a similar problem? How was it resolved?
 

HCooke

Member
Region
USA
I have had the same issue with my Platinum Interceptor. I solved it by turning off the3 bike and restarting it. Happened twice.
 

opimax

Well-Known Member
Region
USA
City
Atlanta
If you switch bikes does the issue follow the bike or the rider? Just to verify
 

HCooke

Member
Region
USA
I don't have this issue on other bikes. No rides the Interceptor except me. It has only happened twice and is not currently an issue.
 

Brian-s

New Member
Region
USA
Does it do this if you turn either the pedal assist or the torque assist off? I had issues with my Platinum City commuter, and the store owner says sometimes the computer doesn't like both the pedal assist and the torque both being on