my juggernaut ultra FS struggles (LBS CAUSED 99%)

lordnox09

Member
so i bought my ultra FS in September last year and in october my rear hub went i contacted biktrix support and was told to take it to my LBS for repair (i informed them my LBS is useless) but figured i would go about it the way i was asked. I try to do repairs myself as they are useless and expensive) was then given the run around by my LBS until April when they finally said they where unable to get the hub for my bike after contacting biktrix (im assuming they just wanted the part of the hub with the pawls on it)

so i then contacted biktrix again about getting a new hub for my 2020 ultra fs was then informed that it would be 160$ so i spent the $ for the hub so i brought the hub into the shop and his reply was oh thats the same part we coulda got

i then leave it with them a week and get it back take it home throw it on my bike and snap bang boom there goes the hub again my cassette is spinning but the tire is not moving again so i call the shop and aske them if they actually replaced the hub they say yes so i bring the bike tire back to the shop and show them then find out they took the middle from the new hub and stuck it in the old hub body

they then take it upon themselves to actually switch the hub for me and re spoke the rim i then get it back from them and put it back on my bike and take it for a test ride and now there is a weird grinding/ vibration coming from my rear end between 20-30 km/h above or below those speeds its not really noticeable but im afraid to take it back to the LBS now until it completely broken cause i don't wanna go another 6 months

The main issue i have my bike is almost a year old now and i have only had it up and running for a max of 2 months and then the worst happened i watch ranger review and wess neal on youtube and they both have biktrix bikes and both of them had there hubs go on there bikes waaaaay after mine and they where both sent whole new rims to fix the issue and free of charge as far as i know how is it my bike was 1 month old when it happened yet it cost me 160$ for the part and the entire run around for 6 months and more at the shop to get the repairs and by the feeling of my back tire they still didn't fix it and its gonna happen again and there both back up and running again in a week or 2

the city i live in is almost anti E bike 2 bike shops wont take the bike cause "insurance issues" one wants an arm and a leg for everything and the greenstreet shop (ebike store) i broke my chain 200km and tried to get a new one and they wanted me to replace my entire drivetrain or they wouldn't even sell me a chain. i said mid drive his response was oh where talking money then i turned around after 30s of his nonsense

now i broke my derailleur hanger and been waiting to get that shipped to me cause its not listed on the website so had to take the long road through support maybe i can ride again next week
 

Ridetoglide

Member
Region
USA
Thats the only real risk/problem with buying high powered ebikes (750 watt +) online. Although biktrix customer service is pretty good its not like you can take the bike back to the store where it was purchased for repairs and many LBS dont or wont work on ebikes. It really helps if you can work on your own bike in this situation. Between amazon and youtube i can buy almost any tool i need and watch any video i need to illustrate the repair.
 
Last edited:

lordnox09

Member
Thats the only real risk/problem with buying high powered ebikes (750 watt +) online. Although biktrix customer service is pretty good its not like you can take the bike back to the store where it was purchased for repairs and many LBS dont or wont work on ebikes. It really helps if you can work on your own bike in this situation. Between amazon and youtube i can buy almost any tool i need and watch any video i need to illustrate the repair.
that was my plan but i figured if there was any warranty with it then they would go thorugh LBS easier than me

when i said my hub was gone they said take it to my LBS i think in 3 of my convo i mentioned my LBS was useless but then when i brought my tire back in for them to actually change the hub over they where astonished that i had to buy the part to fix it that's why they didn't swap it and re spoke at first to try to make it a free fix as they didn't charge me for the 6 month service job lol

almost at the point of just buying a new set of rims for it but i dont wanna waste the money when the first set should have no issues maybe i can work something out to buy 2 get one free with biktrix
 

greeno

Active Member
Region
USA
City
San Diego
I know your pain a buddy of mine bought the same bike about the same time as you and a month later he blows out the rear hub. Lower end hubs on the original build and the Internal notches inside the hub portion that the pawls ride on were shot. He contacted Biktrix and got no help. Internal parts weren't available so he bit the bullet and we ordered a quality DT Swiss hub, ordered some new spokes then we took his old wheel apart and then I laced him up a new rear wheel. Nice to now someone who can build wheels and he's been fine ever since. The issue I see is having a 190mm rear end... lots of flex. Sorry for your troubles.
 

lordnox09

Member
from look of the hub there is many more pawls then any other I've seen there is 2 sets side by side and about 10 or 12 on each so about 24 pawls i think it may have just been a bad batch of hubs they got so they couldn't fully engage like the splines in the body where not quite deep enough groove

i just re read what you said and yeah seems like the same issue the body of the hub was shot
 

TForan

Well-Known Member
On my fourth year with my Ultra and zero problems other than routine maintenance. Also, Any LBS around here will work on it. Sorry to hear of your problems but it isn't widespread , IMO.
 
Last edited:

Gionnirocket

Well-Known Member
Region
USA
City
Y. O.
so i bought my ultra FS in September last year and in october my rear hub went i contacted biktrix support and was told to take it to my LBS for repair (i informed them my LBS is useless) but figured i would go about it the way i was asked. I try to do repairs myself as they are useless and expensive) was then given the run around by my LBS until April when they finally said they where unable to get the hub for my bike after contacting biktrix (im assuming they just wanted the part of the hub with the pawls on it)

so i then contacted biktrix again about getting a new hub for my 2020 ultra fs was then informed that it would be 160$ so i spent the $ for the hub so i brought the hub into the shop and his reply was oh thats the same part we coulda got

i then leave it with them a week and get it back take it home throw it on my bike and snap bang boom there goes the hub again my cassette is spinning but the tire is not moving again so i call the shop and aske them if they actually replaced the hub they say yes so i bring the bike tire back to the shop and show them then find out they took the middle from the new hub and stuck it in the old hub body

they then take it upon themselves to actually switch the hub for me and re spoke the rim i then get it back from them and put it back on my bike and take it for a test ride and now there is a weird grinding/ vibration coming from my rear end between 20-30 km/h above or below those speeds its not really noticeable but im afraid to take it back to the LBS now until it completely broken cause i don't wanna go another 6 months

The main issue i have my bike is almost a year old now and i have only had it up and running for a max of 2 months and then the worst happened i watch ranger review and wess neal on youtube and they both have biktrix bikes and both of them had there hubs go on there bikes waaaaay after mine and they where both sent whole new rims to fix the issue and free of charge as far as i know how is it my bike was 1 month old when it happened yet it cost me 160$ for the part and the entire run around for 6 months and more at the shop to get the repairs and by the feeling of my back tire they still didn't fix it and its gonna happen again and there both back up and running again in a week or 2

the city i live in is almost anti E bike 2 bike shops wont take the bike cause "insurance issues" one wants an arm and a leg for everything and the greenstreet shop (ebike store) i broke my chain 200km and tried to get a new one and they wanted me to replace my entire drivetrain or they wouldn't even sell me a chain. i said mid drive his response was oh where talking money then i turned around after 30s of his nonsense

now i broke my derailleur hanger and been waiting to get that shipped to me cause its not listed on the website so had to take the long road through support maybe i can ride again next week
That's Biktrix for you.
Except for the same 4 cheerleaders that always reply with the same praise... it seems this is more accurate to how they operate..
Kinda late... But I would have insisted on a new wheel when it first happened. Sometimes you need to be the squeaky wheel in order to get any results.
What is/was the warranty?
 

lordnox09

Member
i have dealt with there support before for some other things and always had good results

i believe the warranty only covers frame for lifetime and motor for 1 year

i had assumed when i asked about the part when they said take it to LBS i assumed they wanted a "expert" opinion as to not just give away a free wheel to anyone who asks
like i was saying 99% seems to be LBS fault as i dont know how they inquired about the replacement when they asked (i assumed there was a delay in getting parts for the fix pandemic and all)
so months and months past and at that point i was like let me get back on the road already im sick of walking to work everyday 16km
 

Gionnirocket

Well-Known Member
Region
USA
City
Y. O.
i have dealt with there support before for some other things and always had good results

i believe the warranty only covers frame for lifetime and motor for 1 year

i had assumed when i asked about the part when they said take it to LBS i assumed they wanted a "expert" opinion as to not just give away a free wheel to anyone who asks
like i was saying 99% seems to be LBS fault as i dont know how they inquired about the replacement when they asked (i assumed there was a delay in getting parts for the fix pandemic and all)
so months and months past and at that point i was like let me get back on the road already im sick of walking to work everyday 16km
I understand... But you initially had a problem within one month of purchase. And though the LBS has a great deal to do with your outcome, I still think as soon as they verified that there was an issue, a new wheel should have been sent. It can be frustrating but sometimes you need to take a stance, especially with a defective product.
 
Last edited:

roshan

Well-Known Member
i have dealt with there support before for some other things and always had good results

i believe the warranty only covers frame for lifetime and motor for 1 year

i had assumed when i asked about the part when they said take it to LBS i assumed they wanted a "expert" opinion as to not just give away a free wheel to anyone who asks
like i was saying 99% seems to be LBS fault as i dont know how they inquired about the replacement when they asked (i assumed there was a delay in getting parts for the fix pandemic and all)
so months and months past and at that point i was like let me get back on the road already im sick of walking to work everyday 16km
If the local bike shop wasn't able to lace your new hub in a week or two, you should have just contacted us. We could have offered to build the wheel for you or ship a pre-built wheel for you.

It sounds like the LBS replaced your freehub body, but didn't check if the ratchet ring is worn/damaged. Replacing one and not checking the other is really amateurish and it will definitely lead to premature failure.
 

lordnox09

Member
W
If the local bike shop wasn't able to lace your new hub in a week or two, you should have just contacted us. We could have offered to build the wheel for you or ship a pre-built wheel for you.

It sounds like the LBS replaced your freehub body, but didn't check if the ratchet ring is worn/damaged. Replacing one and not checking the other is really amateurish and it will definitely lead to premature failure.
Yeah I had originally assumed there was some sort of delay in getting the parts I was calling the shop every 2 weeks or so and they kept saying still waiting on the part so tell they finally said months later we can't get the part can you call and see if you can get it

At that point I knew they probably never tried cause there is 24/7 chat support and they complained about how hard it is to deal with a Chinese company and I said there Canadian from Saskatchewan he was like oh there Canadian
 

lordnox09

Member
I am still having some issue with it still after getting it back there is a vibration I can feel from 20-30km/h and i have re aligned my brakes so many times and it's more noticeable when I turn but it's coming from the back cause I can spin the tire on the stand and still get the same vibration
 

Gionnirocket

Well-Known Member
Region
USA
City
Y. O.
If the local bike shop wasn't able to lace your new hub in a week or two, you should have just contacted us. We could have offered to build the wheel for you or ship a pre-built wheel for you.

It sounds like the LBS replaced your freehub body, but didn't check if the ratchet ring is worn/damaged. Replacing one and not checking the other is really amateurish and it will definitely lead to premature failure.
How about sending the guy a proper wheel.
You know, what you should have done from the beginning.
 

roshan

Well-Known Member
I am still having some issue with it still after getting it back there is a vibration I can feel from 20-30km/h and i have re aligned my brakes so many times and it's more noticeable when I turn but it's coming from the back cause I can spin the tire on the stand and still get the same vibration
Is the vibration because the tire isn't seated properly on the rim? That would cause it.. Can you check?
 

lordnox09

Member
Is the vibration because the tire isn't seated properly on the rim? That would cause it.. Can you check?
I will run down and check that I did read that could be a problem but pretty confident I got it on right there is no part sticking out or wavy it's a 120 tpi case so went on super easy but will quick 5 min job I'll check it and get back to you
 

roshan

Well-Known Member
I will run down and check that I did read that could be a problem but pretty confident I got it on right there is no part sticking out or wavy it's a 120 tpi case so went on super easy but will quick 5 min job I'll check it and get back to you
If you spin the wheel with the rear wheel in the air, you should be able to tell if the tire isn't spinning round.
 

lordnox09

Member
Waiting on my hanger to come tomorrow and can take it out for a spin still seems to be a small vibration but can. Only spin the tire by hand
If you spin the wheel with the rear wheel in the air, you should be able to tell if the tire isn't spinning round.
I just popped it off the rim and put it back on it's sealed on there good and the tire spins good and straight

And are you meaning like hold the brake and see if the rubber spins around the rim?
 

roshan

Well-Known Member
Waiting on my hanger to come tomorrow and can take it out for a spin still seems to be a small vibration but can. Only spin the tire by hand

I just popped it off the rim and put it back on it's sealed on there good and the tire spins good and straight

And are you meaning like hold the brake and see if the rubber spins around the rim?
Go for a ride tomorrow and keep me posted.
 

lordnox09

Member
Go for a ride tomorrow and keep me posted.
Yeah it still seems to be having the same issue between 20-30 it feels like a vibration but when I lean for a corner it gets stronger almost like a grinding feeling but with no sound but there is a resistance feeling slowing me down but the hub has good engagement for acceleration