New 015 easy motion street with display calibration issues?

RFH

New Member
hi folks. I bought the em street online two weeks ago with a great deal and a local shop set it up. The first problem was the throttle doesn't sit work and we're waiting on a replacement to arrive, but it's still usable in pedal assist. I've noticed that when I bike, it seems to tell me I've done more miles than I have, as if it's calculating in kilometers even though it says miles. The tire size is set correctly at 26. I called the store where I bought it And they don't know. Any thoughts? Fwiw, the speed also seems to be giving it in km even though it says mph. Thanks in advance for an suggestions.
 

Scooteretti

Active Member
hi folks. I bought the em street online two weeks ago with a great deal and a local shop set it up. The first problem was the throttle doesn't sit work and we're waiting on a replacement to arrive, but it's still usable in pedal assist. I've noticed that when I bike, it seems to tell me I've done more miles than I have, as if it's calculating in kilometers even though it says miles. The tire size is set correctly at 26. I called the store where I bought it And they don't know. Any thoughts? Fwiw, the speed also seems to be giving it in km even though it says mph. Thanks in advance for an suggestions.
Hello RFH,

Have you resolved the throttle issue? Note that the throttle mode will only work when you set the assist to "0" mode. If you are in any of the 4 pedal assist modes the throttle is deactivated.

Concerning the display, did you get that resolved yet? If yes what was the outcome/ fix as I have not encountered that issue yet?

Regards,


Will
 

RFH

New Member
Yes thx. Both issues have been resolved.

The throttle was disconnected inside under the battery where it attaches to head to the rear wheel (they had sent a new throttle and that didn't work either. Then they sent the store the wiring configuration and had them check it out and they found the problem).

The display was a problem with the display itself. Easy motion thought it was a programming error and sent me a new display. It worked perfectly and matches gps exactly (in miles this time). Their customer service was awesome in both cases.