New to EBR

F6B

New Member
I have two trek powerfly 8's. Love them. Got first one in 2017 and bought second one this spring.
Have been riding non electric Mtn bikes since 2010. Have several non electric bikes that I rode regularly . Only started to ride the electric regularly 2 years ago. I am starting to get some system glitches on one of the bikes where the screen goes blank and shuts down power assist while riding. The other day I also had an issue where, on the other electric bike, when I tried to move from OFF to ECO or any other assist setting, it would immediately go back to off. couldn't get any assist level to operate.
Has anyone had any issues like that and if so, do you have any recommendations as to what is causing the problem?
Thanks
 
I have two trek powerfly 8's. Love them. Got first one in 2017 and bought second one this spring.
Have been riding non electric Mtn bikes since 2010. Have several non electric bikes that I rode regularly . Only started to ride the electric regularly 2 years ago. I am starting to get some system glitches on one of the bikes where the screen goes blank and shuts down power assist while riding. The other day I also had an issue where, on the other electric bike, when I tried to move from OFF to ECO or any other assist setting, it would immediately go back to off. couldn't get any assist level to operate.
Has anyone had any issues like that and if so, do you have any recommendations as to what is causing the problem?
Thanks
Take them back to the dealer
 

F6B

New Member
Thanks for your reply. I deal with a great Mtn bike shop here in edmonton. I am planning to take them both in but with this current covid situation the number of people heading to this bike shop for service, has gone through the roof. Due to their incredible work load I would be looking at a 1-2 week turn around time. I thought I would check here to see if anyone has had a similar problem that was solved with a simple loose connection or adjustment issue. I am planning to take in this week
 

John from Connecticut

Well-Known Member
I have two trek powerfly 8's. Love them. Got first one in 2017 and bought second one this spring.
Have been riding non electric Mtn bikes since 2010. Have several non electric bikes that I rode regularly . Only started to ride the electric regularly 2 years ago. I am starting to get some system glitches on one of the bikes where the screen goes blank and shuts down power assist while riding. The other day I also had an issue where, on the other electric bike, when I tried to move from OFF to ECO or any other assist setting, it would immediately go back to off. couldn't get any assist level to operate.
Has anyone had any issues like that and if so, do you have any recommendations as to what is causing the problem?
Thanks

Howdy, I believe your bikes have the Purion controller so my suggestion may not apply ? If your controller is removable ( slides in and out of a click bracket ) remove it
and reseat it. I have a three year old Trek Powerfly7 with the Bosch Intuvia Controller and have experienced a very similar problem a couple of times. I simply
slide the controller out of it's click bracket, reseat and I'm good to go. Good Luck.

John