no mph or mileage reading on purion

B Mac

New Member
Region
USA
PedalUma, Alaskan and Stefan Mikes
Just showing him the Allant+7 look vs the picture you used. Here are both.
Just an update on this thread that I started about a month ago. After about 26 miles the speedometer stopped working on our Allant 7. At times we would get the 503 error message but the bike would ride fine otherwise. After about 50 miles of riding the speedometer starting working for the next 25 miles. At that point it started to work erratically and the power assist would also kick in and out. I contacted Trek and they said it was most likely a problem with the contact pins for the battery. A couple of times when I was riding it acted up so I popped the battery out and put it back in. The first 2 or 3 times this worked. Then it no longer worked. At that point I took it into the dealer. I would have taken it earlier but it is an hour drive. I had to leave the bike for a couple hours. When I returned he said he adjusted the speed sensor a little. He didn't know if it solved the problem as he hadn't had a chance to try it out. I took it for a ride that day and several rides since and it has been working perfectly! Not sure why popping the battery out and putting in back in seemed to help. The dealer says he did not make any adjustments on the battery.